[SeaMonkey] xpcshell: "test_clearHistory_shutdown.js | test failed (with xpcshell return code: 0)"

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perma-orange])

(Assignee)

Description

6 years ago
The test in suite/common/places/tests/unit/test_clearHistory_shutdown.js currently fails on the testboxen due to error while using nsICacheSession.openCacheEntry:

TEST-INFO | /builds/slave/test/build/xpcshell/tests/suite/common/places/tests/unit/test_clearHistory_shutdown.js | running test ...
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/xpcshell/tests/suite/common/places/tests/unit/test_clearHistory_shutdown.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>
### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmp9cx7Sf/runxpcshelltests_leaks.log
WARNING: GetDefaultCharsetForLocale: need to add multi locale support: file ../../../../../../mozilla/intl/locale/src/unix/nsUNIXCharset.cpp, line 105

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-INFO | (xpcshell/head.js) | test 2 pending
Initialize suiteglue before Places
Add visits.
Add cache.

TEST-UNEXPECTED-FAIL | xpcshell/head.js | [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsICacheSession.openCacheEntry]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: /builds/slave/test/build/xpcshell/tests/suite/common/places/tests/unit/test_clearHistory_shutdown.js :: storeCache :: line 136"  data: no]
pldhash: for the table at address 0xb264bf94, the given entrySize of 136 definitely favors chaining over double hashing.


See http://hg.mozilla.org/mozilla-central/rev/72019f633129 for what needs to be ported from the Firefox version of this test. Also see Bug 792804 for a (probably) similar test problem plus patch for the problem.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804972
(Assignee)

Comment 2

6 years ago
Reopening so that this bug is shown on the TBPL log :) otherwise duplicate bugs might get filed again ;)
Status: RESOLVED → REOPENED
Depends on: 804972
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

5 years ago
Underlying bug is fixed, so this one is fixed, too.
Assignee: nobody → bugzilla
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.