If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failure in testAddons_RestartlessExtensionWorksAfterRestart/test1.js | Disconnect Error: Application unexpectedly closed

RESOLVED WORKSFORME

Status

Mozilla QA
Mozmill Tests
P1
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: AlexLakatos, Assigned: Daniela Petrovici)

Tracking

unspecified

Firefox Tracking Flags

(firefox-esr10 wontfix)

Details

(Whiteboard: [mozmill-test-failure] s=130107 u=failure c=addons p=1, URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
TEST: /restartTests/testAddons_RestartlessExtensionWorksAfterRestart/test1.js | testInstallRestartlessExtension
ERROR: Disconnect Error: Application unexpectedly closed
WHEN: 11-18-2012
FIRST: 10-12-2012
FREQ: 7
(Reporter)

Updated

5 years ago
status-firefox-esr10: --- → affected
OS: Linux → Windows XP
Hardware: x86_64 → x86
What's the Mozmill CI link? It would be of much more help here.
(Reporter)

Comment 2

5 years ago
http://10.250.73.243:8080/job/mozilla-esr10_functional/480/
Alex, please rebuild this specific job so we can check if it is reproducible. If not we will have to wait for the next failure.
Priority: -- → P2
(Reporter)

Comment 4

5 years ago
Triggered a rebuild
Alex: What was the result of the rebuild? It's been 5 days, and will be difficult to find the build after such time has passed.
(Reporter)

Comment 6

5 years ago
Only 2 builds on that job in 2012-11-19, and both green.
http://10.250.73.243:8080/job/mozilla-esr10_functional/486/
http://10.250.73.243:8080/job/mozilla-esr10_functional/487/
(Reporter)

Comment 7

5 years ago
Happened again today http://mozmill-ci.blargon7.com/#/functional/report/352218d7e3125c857fc1d371678e7114

Here is the console log: http://10.250.73.243:8080/job/mozilla-esr10_functional/518/console

I went ahead and started a rebuild: http://10.250.73.243:8080/job/mozilla-esr10_functional/524/
(Reporter)

Comment 8

5 years ago
(In reply to Alex Lakatos[:AlexLakatos] from comment #7)
> I went ahead and started a rebuild:
> http://10.250.73.243:8080/job/mozilla-esr10_functional/524/
That rebuild was green
Happened again on Windows XP sp3:
http://mozmill-ci.blargon7.com/#/functional/report/a11aa7b15f4e571fd6fe21a2db077a87
(Assignee)

Comment 10

5 years ago
Happened again on Windows XP SP3:
http://mozmill-ci.blargon7.com/#/functional/report/a11aa7b15f4e571fd6fe21a2dba8425d
Happens very rarely so I would suggest we get this investigated before we close it out. Try to run it in a loop a dozen of times. Might be good to do it also for a heavily loaded system.
Priority: P2 → P3
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure] s=130107 u=failure c=addons p=1
(Assignee)

Updated

5 years ago
Assignee: nobody → dpetrovici
Status: NEW → ASSIGNED
This test has to be skipped immediately. I can see the installation dialog of the restartless.xpi open on all the mac boxes. This is most likely causing the 60s timeout for our Jenkins jobs and affect other testruns.

Please come up with a skip patch ASAP. Thanks.
OS: Windows XP → All
Priority: P3 → P1
Hardware: x86 → All
Created attachment 704831 [details] [diff] [review]
[all except esr10] skip patch

Disabling test for default, aurora, release, beta, esr17.
Attachment #704831 - Flags: review?(hskupin)
Created attachment 704833 [details] [diff] [review]
[esr10] skip patch

Skip patch for esr10.
Attachment #704833 - Flags: review?(hskupin)
Comment on attachment 704831 [details] [diff] [review]
[all except esr10] skip patch

Review of attachment 704831 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/restartTests/testAddons_RestartlessExtensionWorksAfterRestart/manifest.ini
@@ +1,2 @@
>  [test1.js]
> +disabled = Bug 813170 - Test failure 'Disconnect Error: Application unexpectedly closed'

It's enough to disable the toplevel reference of the test. Those two changes in that file are not necessary.
Attachment #704831 - Flags: review?(hskupin) → review-
Comment on attachment 704833 [details] [diff] [review]
[esr10] skip patch

Review of attachment 704833 [details] [diff] [review]:
-----------------------------------------------------------------

Same as for the other patch.
Attachment #704833 - Flags: review?(hskupin) → review-
Created attachment 704844 [details] [diff] [review]
[esr10] skip patch

Updated patch.
Attachment #704833 - Attachment is obsolete: true
Attachment #704844 - Flags: review?(hskupin)
Created attachment 704845 [details] [diff] [review]
[all except esr10] skip patch

Updated for the other branches.
Attachment #704831 - Attachment is obsolete: true
Attachment #704845 - Flags: review?(hskupin)
Comment on attachment 704844 [details] [diff] [review]
[esr10] skip patch

Review of attachment 704844 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/c1ecec0f07d4 (esr10)
Attachment #704844 - Flags: review?(hskupin)
Attachment #704844 - Flags: review+
Attachment #704844 - Flags: checkin+
Comment on attachment 704845 [details] [diff] [review]
[all except esr10] skip patch

Review of attachment 704845 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/d9e0e694cbf2 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/3226c9fe17d9 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/44daf7ddcb52 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/740fc5e78a56 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/5fdc13fef516 (esr17)
Attachment #704845 - Flags: review?(hskupin)
Attachment #704845 - Flags: review+
Attachment #704845 - Flags: checkin+
status-firefox18: --- → disabled
status-firefox19: --- → disabled
status-firefox20: --- → disabled
status-firefox21: --- → disabled
status-firefox-esr17: --- → disabled
Whiteboard: [mozmill-test-failure] s=130107 u=failure c=addons p=1 → [mozmill-test-failure][mozmill-test-skipped] s=130107 u=failure c=addons p=1
Just to add, I have seen the addon installation dialog on all the mac machines today. The Firefox process was no longer responding and I had to force kill all of them. It might be a bug in Firefox which keeps the application hanging but we have to investigate that. Reports shown on the dashboard will only be for Windows and/or Linux, but on OSX the Jenkins job will be killed after 60s. So we do not send any report.

Updated

5 years ago
Depends on: 834635
(Assignee)

Comment 22

5 years ago
I have tried to run for three days (1/25 - 1/27) on release4-osx-107.qa.mtv1.mozilla.com machine with Beta build. I think that the next steps should be:
1) to try with Release builds - run a functional test run for one day
2) to try to reproduce the issue locally, then remotely on Windows XP SP3 using the ESR10 builds starting with the date when it last reproduced and try to find a build where it reproduces at least once.

Please tell me if these steps are ok to investigate the issue
Now with Mozmill 1.5.20 released and activated in the Mozmill CI the application shutdown issue should not happen anymore. This allows me to unskip the test on all branches:

http://hg.mozilla.org/qa/mozmill-tests/rev/5885585e02d8 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/6dc0d34d91df (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/3abf74445177 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/941e6b3499b5 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/ed4aa887f689 (esr17)
http://hg.mozilla.org/qa/mozmill-tests/rev/a30bd82833f1 (esr10)
status-firefox18: disabled → affected
status-firefox19: disabled → affected
status-firefox20: disabled → affected
status-firefox21: disabled → affected
status-firefox-esr17: disabled → affected
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] s=130107 u=failure c=addons p=1 → [mozmill-test-failure] s=130107 u=failure c=addons p=1
(In reply to Daniela Petrovici from comment #22)
> Please tell me if these steps are ok to investigate the issue

I would always try to do this remotely first given the hard-to-reproduce situation we have on local machines. Otherwise it sounds fine.
(Assignee)

Comment 25

5 years ago
The issue did not reproduce with Release build on the MAC machine. Reports are here: http://mozmill-sandbox.blargon7.com/#/functional/reports?branch=18.0&platform=All&from=2013-01-28&to=2013-01-29

I will try on the mm-win-xp-32-3.qa.scl3.mozilla.com machine with ESR10 version from 1/1/2013
status-firefox-esr10: affected → wontfix
(Assignee)

Comment 26

5 years ago
The issue did not reproduce with ESR10 on XP remote machine (mm-win-xp-32-3.qa.scl3.mozilla.com). 

Reports are on http://mozmill-crowd.blargon7.com/#/functional/reports?branch=10.0&platform=Windows%20NT&from=2013-01-28&to=2013-02-15
Have we seen this since the tests were unskipped? If not, I would suggest closing as WORKSFORME and reopening if it reoccurs.
(Assignee)

Comment 28

5 years ago
No, we haven't seen this since the tests were unskipped. Closing as WFM for now.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
status-firefox18: affected → ---
status-firefox19: affected → ---
status-firefox20: affected → ---
status-firefox21: affected → ---
status-firefox-esr17: affected → ---
You need to log in before you can comment on or make changes to this bug.