If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Evaluating 'arguments' as a watch expression always yields an empty pseudo-array

RESOLVED FIXED in Firefox 19

Status

()

Firefox
Developer Tools: Debugger
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: vporof, Assigned: vporof)

Tracking

unspecified
Firefox 20
Points:
---

Firefox Tracking Flags

(firefox19 fixed)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 683149 [details] [diff] [review]
v1
Attachment #683149 - Flags: review?(rcampbell)
Comment on attachment 683149 [details] [diff] [review]
v1

that's probably accurate, isn't it? Since we're evaling inside the scope of that function, arguments is likely just an empty array. Not sure we need to special-case this or not.
(Assignee)

Comment 3

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #2)
> Comment on attachment 683149 [details] [diff] [review]
> v1
> 
> that's probably accurate, isn't it? Since we're evaling inside the scope of
> that function, arguments is likely just an empty array. Not sure we need to
> special-case this or not.

Well, what we're doing is a hack (avoid multiple client evaluation requests), and we shouldn't expose this fact. Neither Chrome nor Firebug has this behavior.
Comment on attachment 683149 [details] [diff] [review]
v1

alrighty then. Maybe this is worthy of a comment around the arguments argument and the regex to help future generations.
Attachment #683149 - Flags: review?(rcampbell) → review+
(Assignee)

Comment 5

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #4)
> Comment on attachment 683149 [details] [diff] [review]
> v1
> 
> alrighty then. Maybe this is worthy of a comment around the arguments
> argument and the regex to help future generations.

Thanks. The regex was there before this patch, but ok.
(Assignee)

Comment 6

5 years ago
Created attachment 683552 [details] [diff] [review]
v1.1

Added comments.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/56f72c68233a
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/56f72c68233a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
(Assignee)

Comment 9

5 years ago
Comment on attachment 683552 [details] [diff] [review]
v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Although a remote use case, evaluating "arguments" (incorrectly) yields an empty pseduo-array.
User impact if declined: Almost none, this patch affects a developer tool, however it's a brand new feature that is likely to get some attention.
Testing completed (on m-c, etc.): fx-team and m-c
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #683552 - Flags: approval-mozilla-aurora?
Attachment #683552 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
New feature, low risk, developer tools only, approving.
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/83fbb172185e
(Assignee)

Updated

5 years ago
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.