Add stacktrace to thrown errors in the web console

RESOLVED DUPLICATE of bug 814497

Status

()

Firefox
Developer Tools: Console
P3
enhancement
RESOLVED DUPLICATE of bug 814497
6 years ago
5 years ago

People

(Reporter: Dan Wolff, Unassigned)

Tracking

18 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-chrome)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121118042012

Steps to reproduce:

1. Open the Web Console
2. Run a JavaScript file which throws an uncaught error


Actual results:

An error was shown in the Web Console, indicating the line where it occured. It is not possible to see the stacktrace.


Expected results:

A stacktrace should be available by clicking on the error, or some other mechanism.
(Reporter)

Updated

6 years ago
Component: Untriaged → Developer Tools: Console
OS: Linux → All
Hardware: x86 → All
Whiteboard: parity-chrome
(Reporter)

Updated

6 years ago
Severity: normal → enhancement
Could cause a performance hit. Maybe through an option in the logging menu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Consolidating some bugs.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814497
You need to log in before you can comment on or make changes to this bug.