Last Comment Bug 813543 - applying padding to box with scroll, bottom-padding doesn't work
: applying padding to box with scroll, bottom-padding doesn't work
Status: RESOLVED DUPLICATE of bug 748518
:
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: 16 Branch
: x86 Mac OS X
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://jsfiddle.net/rwgZu/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 06:09 PST by Philip
Modified: 2012-11-20 12:32 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Philip 2012-11-20 06:09:23 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Creating webpage:

HTML:
<div id="container">
    <div id="some_info"></div>
</div>

CSS: 
#container {
    padding: 3em;
    overflow-x: hidden;
    overflow-y: auto;
    width: 300px;
    height: 300px;
    background: red;
}

#some_info {
    height: 900px;
    background: #000;
}


Actual results:

The padding-bottom doesn't work properly.


Expected results:

The padding should be the same on all sides, look at this fiddle:

http://jsfiddle.net/rwgZu/
Comment 1 User image Alice0775 White 2012-11-20 11:37:24 PST
maybe dupe of Bug 748518
Comment 2 User image Boris Zbarsky [:bz] (still a bit busy) 2012-11-20 12:32:53 PST
Indeed.

*** This bug has been marked as a duplicate of bug 748518 ***

Note You need to log in before you can comment on or make changes to this bug.