Closed Bug 813546 Opened 7 years ago Closed 6 years ago

java.lang.NullPointerException: key == null at android.support.v4.util.LruCache.get(LruCache.java)

Categories

(Firefox for Android :: General, defect, critical)

19 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox18 --- unaffected
firefox19 --- affected
firefox20 --- affected
firefox21 --- affected
firefox22 --- fixed
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: scoobidiver, Assigned: lucasr)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash][startupcrash])

Crash Data

Attachments

(1 file)

There's one crash in 20.0a1/20121120: bp-350b2a97-25ed-42a8-a174-379b42121120.

java.lang.NullPointerException: key == null
	at android.support.v4.util.LruCache.get(LruCache.java:63)
	at org.mozilla.gecko.Favicons.getFaviconFromMemCache(Favicons.java:129)
	at org.mozilla.gecko.AllPagesTab.getUrlsWithoutFavicon(AllPagesTab.java:749)
	at org.mozilla.gecko.AllPagesTab.loadFaviconsForCurrentResults(AllPagesTab.java:784)
	at org.mozilla.gecko.AllPagesTab.access$1700(AllPagesTab.java:61)
	at org.mozilla.gecko.AllPagesTab$AllPagesHandler.handleMessage(AllPagesTab.java:852)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4745)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:786)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+key+%3D%3D+null+at+android.support.v4.util.LruCache.get%28LruCache.java%29
Hmm, 2 crashes on the 20th, none since then...
Here is a recent crash in Nightly: bp-3267f7b9-21b4-4efb-b48d-99e372130108.
Aurora is also affected.
Lucas, does this LruCache exception look like a regression from favicon bug 808027?
Blocks: 808027
(In reply to Chris Peterson (:cpeterson) from comment #3)
> Lucas, does this LruCache exception look like a regression from favicon bug
> 808027?

Doesn't seem so. I can have a look.
Assignee: nobody → lucasr.at.mozilla
Keywords: regression
Version: Trunk → Firefox 19
Duplicate of this bug: 843636
A comment says: "Imported bookmarks and the browser crashes. Pls fix."
Looks like the user was on a Note II, Aaron would have a try at this?
Flags: needinfo?(aaron.train)
Using Firefox (20), and Firefox Beta (21) on my Note II, I tried importing bookmarks and history from stock and Chrome multiple times and in-conjunction with Sync and without Sync enabled and that didn't reproduce any crash. In what conditions will a getFaviconFromMemCache() get called from?
Flags: needinfo?(aaron.train)
Another comment: "Tried to type in the address bar, and it crashed almost instantly"
Assignee: lucasr.at.mozilla → nobody
Assignee: nobody → lucasr.at.mozilla
Attachment #757905 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/d0fc4f35656c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
It's #62 crasher in 21.0, #19 in 22.0b4, and #28 in 23.0a2.
It deserves at least an uplift to Aurora and maybe Beta if it's safe enough.
(In reply to Scoobidiver from comment #13)
> It's #62 crasher in 21.0, #19 in 22.0b4, and #28 in 23.0a2.
> It deserves at least an uplift to Aurora and maybe Beta if it's safe enough.

Agreed. Lucas, can you request uplift?
Comment on attachment 757905 [details] [diff] [review]
Guard against null keys when queryng favicon mem cache

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 785945
User impact if declined: Crashes
Testing completed (on m-c, etc.): Landed in m-c, no issues found.
Risk to taking this patch (and alternatives if risky): This is a very low-risk patch. Just adds a null check to guard against this crash.
String or IDL/UUID changes made by this patch: n/a
Attachment #757905 - Flags: approval-mozilla-aurora?
Comment on attachment 757905 [details] [diff] [review]
Guard against null keys when queryng favicon mem cache

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 785945
User impact if declined: Crashes
Testing completed (on m-c, etc.): Landed in m-c, no issues found.
Risk to taking this patch (and alternatives if risky): This is a very low-risk patch. Just adds a null check to guard against this crash.
String or IDL/UUID changes made by this patch: n/a
Attachment #757905 - Flags: approval-mozilla-beta?
Attachment #757905 - Flags: approval-mozilla-beta?
Attachment #757905 - Flags: approval-mozilla-beta+
Attachment #757905 - Flags: approval-mozilla-aurora?
Attachment #757905 - Flags: approval-mozilla-aurora+
Whiteboard: [native-crash] → [native-crash][startupcrash]
Duplicate of this bug: 810270
You need to log in before you can comment on or make changes to this bug.