Closed Bug 813569 Opened 8 years ago Closed 8 years ago

Long string (ONE_MOMENT) not fully displayed in localized stub installer

Categories

(Firefox :: Installer, defect)

x86_64
Windows 8
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 23
Tracking Status
firefox21 --- verified
firefox22 --- verified
firefox23 --- verified

People

(Reporter: flod, Assigned: robert.strong.bugs)

Details

(Whiteboard: [stub=])

Attachments

(2 files)

See screenshot, bottom of the window.

The full string is "Ancora qualche istante, $BrandShortName verrà avviato al termine dell'installazione…", the last part is not displayed.

http://mxr.mozilla.org/l10n-central/source/it/browser/installer/nsisstrings.properties#29
Whiteboard: [stub=]
Attached patch patch rev1Splinter Review
Went with allowing it to be multiline for the few cases where this happens. Also made the it so the set as default text does the right thing just in case. We might be able to add code to try to align this properly but we are going to go with this for at least the time being.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #734986 - Flags: review?(netzen)
Forgot to mention that the changes are just to the resources in other-licenses\nsis\nsisui.exe
Attachment #734986 - Flags: review?(netzen) → review+
https://hg.mozilla.org/mozilla-central/rev/80be27b3bb36
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 734986 [details] [diff] [review]
patch rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Stub installer / bug 322206
User impact if declined: some locales will have cut off text
Testing completed (on m-c, etc.): manually verified and it has been on m-c for a while.
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #734986 - Flags: approval-mozilla-beta?
Attachment #734986 - Flags: approval-mozilla-aurora?
Attachment #734986 - Flags: approval-mozilla-beta?
Attachment #734986 - Flags: approval-mozilla-beta+
Attachment #734986 - Flags: approval-mozilla-aurora?
Attachment #734986 - Flags: approval-mozilla-aurora+
The text is complete on FF 21b7 stub installer en-US, it, fr.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/22.0

Verified as fixed with FF 22 beta 1 (Build ID: 20130514181517) stub installer en-US, it and es-ES.
Verified fixed FF 23b6 stub installer en-US, it, fr.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.