bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Context menu stops GIF animation

RESOLVED DUPLICATE of bug 808466

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 808466
6 years ago
6 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 683596 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0
Build ID: 20121120030739

Steps to reproduce:

1. Open a gif image like this :   http://upload.wikimedia.org/wikipedia/commons/thumb/2/2c/Rotating_earth_%28large%29.gif/200px-Rotating_earth_%28large%29.gif

2. Right click anywhere in the browser such that a context menu opens.
3. Move mouse inside the context menu.


Actual results:

The animation stops


Expected results:

Not so.
I can reproduce this in older builds with the unsure regression range:
Last good nightly: 2012-09-28
First bad nightly: 2012-09-29

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=895f66c4eada&tochan
ge=c09a0c022b2e

but it works for me with  
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 
20121120030739

Comment 2

6 years ago
WFM:
2012-09-28-03-05-44-mozilla-central-firefox-18.0a1.ru.linux-x86_64

bug:
2012-10-02-03-05-26
2012-10-16-03-05-44

WFM:
2012-10-22-03-05-51
2012-10-23-03-05-53
2012-11-01-03-07-05

WFM: 20121120030739 Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20.0 Firefox/20.0

Comment 3

6 years ago
bug 801784

Updated

6 years ago
Component: Untriaged → Layout
Product: Firefox → Core

Comment 4

6 years ago
Reporter, you reported this previous bug (bug 786585), is it similar?
(Reporter)

Comment 5

6 years ago
No, #786585 is different.

This bug is almost a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=801784 .  Though i dont know why i am still able to reproduce this issue.
This works for me too, and definitely seems very similar to bug 801784. Very weird that it still occurs for you though.
(Reporter)

Comment 7

6 years ago
i can reproduce in a new profile. I tried switching off layers acceleration and azure content. But no go.

Comment 8

6 years ago
Created attachment 695515 [details]
about:support of new profile

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20121224 Firefox/20.0
BuildID: 20121224030902

I can reproduce it from a new profile in Windows 8 with a blocklisted graphic driver, i.e. no hardware acceleration. The driver is Catalyst 12.6 legacy, which is the latest one available for my old ATI HD3650 card.

Right-clicking and moving the cursor into context menu stops the gif animation, but another right-clicking would resume the animation.

Comment 9

6 years ago
Created attachment 695516 [details]
about:support of main profile

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20121224 Firefox/20.0
BuildID: 20121224030902

However, the behaviour is different in my main profile. The gif animation only halts for about 0.5 seconds every time I move the cursor into or out of the context menu area, while keeping the menu opened at all times.

I have force enable direct2d and layer acceleration in this profile by setting gfx.direct2d.force-enabled and layers.acceleration.force-enabled to true, but the result is still the same (0.5s halt) even if I reset both of them to false.
Depends on: 808466
(Reporter)

Comment 10

6 years ago
This has mostly been solved by bug 808466 except for one thing :  When you click-and-hold the mouse pointer on the window frame, the GIF stops animating for ~ 1 second.
(Reporter)

Comment 11

6 years ago
i think this bug  should be marked resolved fixed by bug 808466
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 12

6 years ago
oops. Apparently i dont have permission to mark bugs as resolved fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Either it's a dupe of that bug or it's wfm if you are unsure
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

6 years ago
a dupe, then.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 808466

Updated

6 years ago
No longer depends on: 808466
You need to log in before you can comment on or make changes to this bug.