crash @ js::gc::MarkCycleCollectorChildren(JSTracer*, js::Shape*)

RESOLVED DUPLICATE of bug 813619

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 813619
5 years ago
5 years ago

People

(Reporter: SpeciesX, Unassigned)

Tracking

({crash})

Trunk
x86_64
Windows 8
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
Signature 	js::gc::MarkCycleCollectorChildren(JSTracer*, js::Shape*) More Reports Search
UUID	7fdf2779-f1a2-4421-a753-f8d342121120
Date Processed	2012-11-20 15:10:41
Uptime	78
Last Crash	1.4 minutes before submission
Install Age	12.5 minutes since version was first installed.
Install Time	2012-11-20 14:57:53
Product	Firefox
Version	20.0a1
Build ID	20121120030739
Release Channel	nightly
OS	Windows NT
OS Version	6.2.9200
Build Architecture	amd64
Build Architecture Info	family 16 model 4 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xffffffffffffffff
User Comments	
App Notes 	

AdapterVendorID: 0x1002, AdapterDeviceID: 0x9440, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.970.100.3000

D2D! D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ WebGL! EGL? EGL+ GL Context? GL Context+ WebGL+ 

Processor Notes 	
EMCheckCompatibility	True

Adapter Vendor ID	0x1002
Adapter Device ID	0x9440
Total Virtual Memory	8796092891136
Available Virtual Memory	8795278704640
System Memory Use Percentage	20
Available Page File	7667683328
Available Physical Memory	6827786240


0 	xul.dll 	js::gc::MarkCycleCollectorChildren 	js/src/gc/Marking.cpp:877
1 	xul.dll 	xul.dll@0x4bc7ef 	
2 	xul.dll 	NoteJSChildTracerShim 	js/xpconnect/src/nsXPConnect.cpp:806
3 	xul.dll 	NoteJSChildTracerShim 	js/xpconnect/src/nsXPConnect.cpp:807
4 	xul.dll 	XPCWrappedNative::GetWrappedNativeOfJSObject 	js/xpconnect/src/XPCWrappedNative.cpp:1929
5 	xul.dll 	GCGraphBuilder::NoteXPCOMChild 	xpcom/base/nsCycleCollector.cpp:1952
6 	xul.dll 	js::gc::Mark<JSAtom> 	js/src/gc/Marking.cpp:151
7 	xul.dll 	js::gc::MarkUnbarriered<JSScript> 	js/src/gc/Marking.cpp:143
8 	xul.dll 	DescribeGCThing 	js/xpconnect/src/nsXPConnect.cpp:801
9 	xul.dll 	proxy_TraceObject 	js/src/jsproxy.cpp:2847
10 	xul.dll 	proxy_TraceFunction 	js/src/jsproxy.cpp:2856
11 	xul.dll 	js::gc::Mark<js::Shape> 	js/src/gc/Marking.cpp:151
12 	xul.dll 	NoteGCThingJSChildren 	js/xpconnect/src/nsXPConnect.cpp:817
13 	xul.dll 	nsXPConnect::GetXPConnect 	js/xpconnect/src/nsXPConnect.cpp:140
14 	xul.dll 	xul.dll@0x2881ff 	
15 	xul.dll 	XPCWrappedNativeScope::GetRuntime 	js/xpconnect/src/nsXPConnect.cpp:243
16 	xul.dll 	nsXPConnectParticipant::TraverseImpl 	js/xpconnect/src/nsXPConnect.cpp:893
17 	xul.dll 	GCGraphBuilder::Traverse 	xpcom/base/nsCycleCollector.cpp:1856
18 	xul.dll 	nsCycleCollector::MarkRoots 	xpcom/base/nsCycleCollector.cpp:2171
19 	xul.dll 	nsCycleCollector::BeginCollection 	xpcom/base/nsCycleCollector.cpp:2850

https://crash-stats.mozilla.com/report/index/bp-7fdf2779-f1a2-4421-a753-f8d342121120
(Reporter)

Updated

5 years ago
Keywords: crash
Hardware: x86 → x86_64

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813619
You need to log in before you can comment on or make changes to this bug.