Closed Bug 813705 Opened 8 years ago Closed 8 years ago

Uninitialized use of rv

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: jdm, Assigned: jdm)

References

Details

Attachments

(1 file)

http://mxr.mozilla.org/mozilla-central/source/layout/base/nsPresContext.cpp#425

If the |if (aLanguage && mLangService) {| block is not taken, rv remains uninitialized when the NS_FAILED(rv) condition is checked.
Duplicate of this bug: 806578
(per bug 806578 comment 0, this code was added in bug 416581 "part 2" -- marking as dependent on that bug)
Depends on: 416581
https://hg.mozilla.org/mozilla-central/rev/cc266c0b96aa
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.