Last Comment Bug 813787 - Remove support for image-sniffing-services
: Remove support for image-sniffing-services
Status: RESOLVED FIXED
: addon-compat
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla20
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks: 813438
  Show dependency treegraph
 
Reported: 2012-11-20 16:01 PST by :Ehsan Akhgari
Modified: 2012-11-21 17:02 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (3.53 KB, patch)
2012-11-20 16:08 PST, :Ehsan Akhgari
joe: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-11-20 16:01:04 PST
This code is supposed to be dead since Firefox 3.  A quick look at mozilla.org tells me that we just shipped Firefox 17.  Need I say more?
Comment 1 :Ehsan Akhgari 2012-11-20 16:08:52 PST
Created attachment 683779 [details] [diff] [review]
Patch (v1)
Comment 2 Joe Drew (not getting mail) 2012-11-20 18:10:45 PST
This will change our addon story, even though it's hardly an important piece of addon compat. For whoever triages this: addons that provide the "image-sniffing-services" XPCOM category will no longer have any effect in core Gecko code.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-11-21 17:02:20 PST
https://hg.mozilla.org/mozilla-central/rev/983af423d488

Note You need to log in before you can comment on or make changes to this bug.