Java 7 Update 09 not working in OS X 10.7.5 (Lion). (Works fine in Mountain Lion)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P5
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Leif Halvard Silli, Unassigned)

Tracking

17 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 683803 [details]
screenshot-non-loading-java-applet.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

1. Installed Java 7 Update 9.
2. Installed the Apple software update that disables the old java support
3. Opened the Java test page at http://java.com/en/download/testjava.jsp


Actual results:

Nothing: No message that the applet *did not load*. And no message that the appled *did* load.

For the record, I also checked about:plugins, which seems to indicate that java is OK.

I also read this page, and tried the tricks recommended there: http://support.mozilla.org/no/questions/940043

More seriously, I can't log into my internet bank anymore (using Firefox, that is). (Workaround: use Safari. Or use a mac with OSX Mountain Lion - it seems to work there.)


Expected results:

There should have been a message saying that java is installed and is working. Or eventually should there have been a message that said that it did NOT work. (Apparently Firefox doesn't perceive any error.)
(Reporter)

Comment 1

5 years ago
Created attachment 683806 [details]
Screenshot from about:plugins, to show the Java is reported to be working.
Component: Untriaged → Plug-ins
Product: Firefox → Core
> 1. Installed Java 7 Update 9.

What, exactly, did you install?  Where did you get it?

As of fairly recently, Apple stopped distributing its own Java plugin (licensed from Sun/Oracle), and expects people to install Oracle's.  Accordingly, Apple's most recent Java "updates" (for OS X 10.6 through 10.8) just delete Apple's own Java plugin.

But then you should be prompted to install Oracle's Java plugin when you click on a Java applet.
Oracle's current Java plugin for OS X does happen to be called "Java SE 7 Update 09".  I just tested it with http://java.com/en/download/testjava.jsp, on OS X 10.7.5, and had no problems.  But it took a few seconds for the applet to display.  Maybe you just didn't wait long enough?

Please try again after restarting both your computer and Firefox.  Also try with the current release version of Firefox (which is FF 17).  That's what I tested with.
(Reporter)

Comment 4

5 years ago
(In reply to Steven Michaud from comment #2)
> > 1. Installed Java 7 Update 9.
> 
> What, exactly, did you install?  Where did you get it?

Got Java 7 from here: http://java.com/en/

> As of fairly recently, Apple stopped distributing its own Java plugin
> (licensed from Sun/Oracle), and expects people to install Oracle's. 
> Accordingly, Apple's most recent Java "updates" (for OS X 10.6 through 10.8)
> just delete Apple's own Java plugin.

As I wrote initially: "2. Installed the Apple software update that disables the old java support".

I have deleted the old plugins.

> But then you should be prompted to install Oracle's Java plugin when you
> click on a Java applet.

I have installed Oracle's Java Plugin. And it works fine. But not in Firefox 17.

(In reply to Steven Michaud from comment #3)
> Oracle's current Java plugin for OS X does happen to be called "Java SE 7
> Update 09".  I just tested it with http://java.com/en/download/testjava.jsp,
> on OS X 10.7.5, and had no problems.  But it took a few seconds for the
> applet to display.  Maybe you just didn't wait long enough?

How many seconds did you wait? I have waited minutes ...

> Please try again after restarting both your computer and Firefox.  Also try
> with the current release version of Firefox (which is FF 17).  That's what I
> tested with.

I have restarted the machine a few times since then. I have also tried with installing new profiles etc. 

I will also say that it is no problem finding people online that complain about the same thing. (I provided one link in the initial comment.)
> 1. Installed Java 7 Update 9.
> 2. Installed the Apple software update that disables the old java support

Sorry I hadn't noticed your step 2.

But as I've said, I can't reproduce what you report.  And I have no idea why you're seeing it.

Just for the sake of completeness, try reinstalling Oracle's Java 7 Update 9.  It may have made a difference that you (apparently) ran Apple's deinstaller/"updater" after you installed Oracle's Java plugin.  (I ran the "deinstaller" first.)
Here's the installer I downloaded from Oracle (its filename):

jre-7u9-macosx-x64.dmg

Is this what you downloaded (and installed)?
(Reporter)

Comment 7

5 years ago
jre-7u9-macosx-x64(1).dmg(In reply to Steven Michaud from comment #6)

> jre-7u9-macosx-x64.dmg
>
> Is this what you downloaded (and installed)?

(In reply to Steven Michaud from comment #5)

> Just for the sake of completeness, try reinstalling Oracle's Java 7 Update
> 9.  It may have made a difference that you (apparently) ran Apple's
> deinstaller/"updater" after you installed Oracle's Java plugin.  (I ran the
> "deinstaller" first.)

Have tried. 

But may be if I could 

    a) un-install Java 7 and 
    b)  un-disable Java 6, and *then* 
    c) disable Java 6 before 
    d) installing java 7 again? 

However, I am not sure how I perform a) and b).
(Reporter)

Comment 8

5 years ago
(In reply to Steven Michaud from comment #6)
> Here's the installer I downloaded from Oracle (its filename):
> 
> jre-7u9-macosx-x64.dmg
> 
> Is this what you downloaded (and installed)?

Sorry for my unclear reply. The answer is yes.
> a) un-install Java 7 and 
> b) un-disable Java 6

I suspect neither of these steps is possible.

Try looking through the settings in your Java preference panel, to make sure everything is enabled that should be.

By the way, does your problem happen with all applets, or just some?

For example does it happen with this?
http://www.math.clemson.edu/~warner/JavaClass/Java/demo/Clock/example1.html
(Reporter)

Comment 10

5 years ago
FWIW, Apple has a description of how to disable Java 7 - and I can verity that it works: http://support.apple.com/kb/HT5559
(Reporter)

Comment 11

5 years ago
(In reply to Leif Halvard Silli from comment #10)
> FWIW, Apple has a description of how to disable Java 7 - and I can verity
> that it works: http://support.apple.com/kb/HT5559

That method enabled me to get Java 6 working. But Java 7 continue to not work in Firefox.
(Reporter)

Comment 12

5 years ago
(In reply to Steven Michaud from comment #9)

> By the way, does your problem happen with all applets, or just some?
> 
> For example does it happen with this?
> http://www.math.clemson.edu/~warner/JavaClass/Java/demo/Clock/example1.html

Yes, it happens with that clock too. 

You know, when I click in the location where the clock is supposed to be, then I see a the dotted frame - the "content holder" so to speak, for the clock. But I don't see the clock itself. So, the behavior is different from when Java is completely disabled - because then, one will be getting a link or button explaing where to download Java. I don't get that download button. So apparently Firefox consider Java to be present, but it is just that nothing happens.
(Reporter)

Comment 13

5 years ago
So this is strange:

I've now found that Java works. But when I use my normal user account, then it does not work *if* the name of the Firefox application folder is "Firefox.app". Thus, if I change the name to "FirefoxFoo.app", for instance, then it will work just fine. Also, if I create a new user account on my Mac and log in there, then "Firefox.app" works just fine.

(Btw: I have several copies of Firefox side-by-side in my Applications folder, most of them with names such as Firefox10.app etc. But the release version is usually called "Firefox.app".)

Does this give you or anyone an idea of what it could be?
> Does this give you or anyone an idea of what it could be?

No.  Though I can't help but think that this must be due to some factor external to Firefox.

I just tried FF 17 (as /Applications/Firefox.app) on OS X 10.7.5 with http://java.com/en/download/testjava.jsp, and had no problems.
It may be worthwhile to try rebuilding your LaunchServices database.

In Terminal run the following command (no line breaks):

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support lsregister -kill -r -domain local -domain system -domain user
Oops, got it wrong.  The following should be correct:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Comment 17

5 years ago
(In reply to Leif Halvard Silli from comment #13)
> So this is strange:
> 
> I've now found that Java works. But when I use my normal user account, then
> it does not work *if* the name of the Firefox application folder is
> "Firefox.app". Thus, if I change the name to "FirefoxFoo.app", for instance,
> then it will work just fine. Also, if I create a new user account on my Mac
> and log in there, then "Firefox.app" works just fine.
> 
> (Btw: I have several copies of Firefox side-by-side in my Applications
> folder, most of them with names such as Firefox10.app etc. But the release
> version is usually called "Firefox.app".)
> 
> Does this give you or anyone an idea of what it could be?

I had exactly the same problem and renaming Firefox.app to Firefox19.app wors for mw as well...

Running:
FF 19.0.2
Java (from oracle) 1.7.0_15, 64-bit
Mac ox x 10.8.2

I tried running /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user, as suggested with no success.
Priority: -- → P5
Something just occurred to me:  I wonder if it makes a difference what you set your default language to in the OS, or which language version of Firefox you're using?
Or for that matter if there are different language releases of Oracle's Java plugin, and if *that* makes a difference?
(Reporter)

Comment 20

5 years ago
So here is some good news - at least for myself: Java now works. This is what happened:

I noticed that if I logged in to my computer as another user, then Java did work. And so, inspired by that, I today I decided to try to get it to work agian in the main user account.

1) I toggled between 32 bit and 64 modus. (That is: I ran for a while in 32 bit modus. And then in 64 bit modus.) In fact, I think I have been running in 32 bit mode for a while - however this is not the original cause of the problems.) 
2) I opened about:confiig and changed all settings related to 'plugin' back to their default settings.

After that it began working again.
Good to hear. Closing assuming some local configuration issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.