Closed Bug 81382 Opened 21 years ago Closed 17 years ago

add support for CSS3 multi-columns

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 251162
Future

People

(Reporter: unger, Assigned: roc)

References

()

Details

(Keywords: css3, qawanted, Whiteboard: (don't add comments before the draft is in CR))

From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)
BuildID:    2001050515

Colums properties like 
<div style="columns: 2; column-gap: 50px;
   column-rule: 1px solid black">
are ingnored.


Reproducible: Always
Steps to Reproduce:
1. Enter <div style="columns: 2; column-gap: 50px;
   column-rule: 1px solid black">...</div>
2.
3.

Actual Results:  No columns.

Expected Results:  2 columns with column-rule.
I believe multiple columns are CSS3, not CSS2.
columns are css3.  setting status to new, but unless this blocks internal mozilla 
code this will probably not be in for a bit... Full support for CSS1/CSS2 is more 
important.  Helpwanted.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css3, helpwanted
OS: Windows 98 → All
Hardware: PC → All
Summary: CSS2: columns property is not rendered → CSS3: columns property is not rendered
Columns could be CSS 3 if CSS 3 was already a specification... For the moment,
multi-columns in CSS are only a Working Draft [1], a work in progress.

Tagging [RFE] and pushing to Future. Cc:ing Marc Attinasi for his information.
Severity: normal → enhancement
Summary: CSS3: columns property is not rendered → [RFE] add support for CSS 3 multi-columns
Target Milestone: --- → Future
Maybe it should be checked if multi-columns can cause changes in the concepts
of the rendering engine - if yes, preparations should be made.
Priority: -- → P4
Assigning pierre's remaining Style System-related bugs to myself.
Assignee: pierre → dbaron
Summary: [RFE] add support for CSS 3 multi-columns → add support for CSS 3 multi-columns
I know this is probably very far from the list of priorities, but I'm voting for
this one. My rationale:

<li>the amazing number of ugly hacks people have been using to emulate this effect

<li>and the fact that an experimental implementation would help this particular
module of css3 move forward - it seems to be quite stalled.
Why 'helpwanted'? The draft isn't even correct yet. Look for example to chapter
10 (<http://www.w3.org/TR/css3-multicol/#floating>).
Summary: add support for CSS 3 multi-columns → add support for CSS3 multi-columns
Keywords: helpwantedqawanted
Priority: P4 → --
Whiteboard: (don't add comments before the draft is in CR)
Depends on: 245297
I'm working on this
Assignee: dbaron → roc

*** This bug has been marked as a duplicate of 251162 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.