Closed Bug 813844 Opened 8 years ago Closed 3 months ago

Port confvars.sh changes from Bug 718067 and package.manifest.in changes from Bug 808219 (Firefox Health Reporter service)

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: philip.chee, Unassigned)

References

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
And Port package.manifest.in changes from Bug 808219 (Firefox Health Reporter service;)
Depends on: 808219
Summary: Port confvars.sh changes from Bug 718067 (Framework for metrics data collection) → Port confvars.sh changes from Bug 718067 and package.manifest.in changes from Bug 808219 (Firefox Health Reporter service)
Attached patch Port patch (v1) (obsolete) — Splinter Review
Assignee: nobody → ewong
Status: NEW → UNCONFIRMED
Ever confirmed: false
Attachment #683868 - Flags: review?(bugspam.Callek)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch Port patch (v2) (obsolete) — Splinter Review
Attachment #683868 - Attachment is obsolete: true
Attachment #683868 - Flags: review?(bugspam.Callek)
Attachment #683923 - Flags: review?(bugspam.Callek)
Comment on attachment 683923 [details] [diff] [review]
Port patch (v2)

Review of attachment 683923 [details] [diff] [review]:
-----------------------------------------------------------------

I'm going to r- since I don't grok the implications of enabling this/doing this without UI and/or Privacy peeking. I'm open to giving it another look if you (or someone) walk me through it. I'm also willing to let another Council Member make a call on "we want this stuff, and its fine with no UI" and then I can r+

Most of the Firefox code to expose this is in browser/ fwiw.
Attachment #683923 - Flags: review?(bugspam.Callek) → review-
So, just as a comment, I think it would be a good idea to add the healthreport code to SeaMonkey, most metrics probably just work, but there has to be some UI to be able to turn it off/on, etc.
This patch is surely a part of what's needed, but there's more to be done for it.
Attached patch Port patch (v3)Splinter Review
Unbitrotted patch + spelling nit.  Forwarding the r-.
Attachment #683923 - Attachment is obsolete: true
Attachment #717707 - Flags: review-
So should this bug be morphed into "[Tracking] Add HealthReport to SeaMonkey"?
Assignee: ewong → nobody
Status: ASSIGNED → NEW

Health reporter is gone now.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.