Cannot use the device because of a black 'mozilla' screen over the homescreen

RESOLVED FIXED

Status

Firefox OS
Gaia::System
P1
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: kaze, Assigned: etienne)

Tracking

({otoro})

unspecified
x86_64
Gonk (Firefox OS)
otoro

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 683928 [details] [diff] [review]
workaround

Latest Gaia & Gecko 18 build. When I start my Otoro, I can see the homescreen very briefly before the black 'mozilla' screen covers it, thus making the phone unusable.

A quick and dirty workaround is to hide the #initlogo element, see attachment.
The regression appears sometime after 01dce6b0559eacbe9546f2f59105ad78c6020e30.
blocking-basecamp: --- → ?
Priority: -- → P1
Assignee: nobody → fbsc
blocking-basecamp: ? → +
Keywords: otoro
I've tried 10 times in my Otoro and this bug is not happening... I've made:
- make reset-gaia (1)
- see 'mozilla logo black screen' disappears, FTU appears
- Run FTU
- Restart again
- Check that everything works properly.
- Go agan to (1)
(Reporter)

Comment 3

5 years ago
Then please use a desktop build, it's much easier to reproduce. All our l10n contributors are complaining about that: as you can guess, it's a complete blocker for them.
I heard about this issue as well, but I can't seem to reproduce.  I've tried gecko 18, 19 and 20 desktop builds.
I've tried with the following:
Desktop build: b2g-20.0a1.en-US.mac64
Gaia: 61fe3087657b27dae854fc2da811c7f2092cb25f

It was impossible for me to reproduce it.
(Assignee)

Comment 6

5 years ago
Driving me crazy, stealing the bug :)
Assignee: fbsc → etienne
Thanks [:etienne], because I've tested a lot of times with B2G-18 (downloaded from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-aurora/) and in my Mac it's impossible to reproduce :S :S :S (I've tested with B2G-19 & B2G-20 as well, and no black screen...)
(Assignee)

Comment 8

5 years ago
Created attachment 686144 [details] [diff] [review]
Patch proposal
Attachment #686144 - Flags: review?(21)
Attachment #686144 - Flags: review?(21) → review+
(Assignee)

Comment 9

5 years ago
https://github.com/mozilla-b2g/gaia/commit/8dc07da79c145e9b6cc417fb630954dc2f0b6e8a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 814161

Comment 11

4 years ago
This issue fixed for  device Ungia; build #20130103070201 v.1
You need to log in before you can comment on or make changes to this bug.