Closed Bug 814149 Opened 8 years ago Closed 8 years ago

Fix CanvasRenderingContext2D::GetCanvas()

Categories

(Core :: Canvas: 2D, defect)

16 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox18 + fixed
firefox19 + fixed
firefox20 --- fixed

People

(Reporter: nrc, Assigned: nrc)

References

Details

Attachments

(1 file)

The old bindings version of GetCanvas() was changed in bug 745025, but the new bindings version was not. The new bindings version should be adjusted and this should be back ported to 18.
Attached patch patchSplinter Review
carrying r=bz from bug 812453 - the patch was split in half, this is part of the r+ed patch with the requested comment.
Attachment #684177 - Flags: review+
We need to backport to 19 as well, right?  Or are we backporting all of bug 812453 to 19?
(In reply to Boris Zbarsky (:bz) from comment #2)
> We need to backport to 19 as well, right?  Or are we backporting all of bug
> 812453 to 19?

Yes, we need to backport this to 18 & 19, and 812453 (the half that is left) to 19.
https://hg.mozilla.org/mozilla-central/rev/abfc7d944d59
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 684177 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 745025
User impact if declined: possible problems printing
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: nonw
Attachment #684177 - Flags: approval-mozilla-beta?
Attachment #684177 - Flags: approval-mozilla-aurora?
Comment on attachment 684177 [details] [diff] [review]
patch

[Triage Comment]
To prevent new printing regressions in Firefox 18, let's uplift this low risk fix to branches.
Attachment #684177 - Flags: approval-mozilla-beta?
Attachment #684177 - Flags: approval-mozilla-beta+
Attachment #684177 - Flags: approval-mozilla-aurora?
Attachment #684177 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.