Closed Bug 814189 Opened 9 years ago Closed 9 years ago

Firefox 17 forgets all cookie permissions each time it is restarted

Categories

(Firefox :: Preferences, defect)

17 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 814554

People

(Reporter: m.richartz, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

Installing Firefox 17 and starting it several times. Starts to ask for cookie permissions every time for every web site that I have permanently disallowed cookies.


Actual results:

With "Accept third-party cookies" *and* Keep until: "ask every time" preference selected, Firefox forgets the settings for those cookie sites that Firefox has been asked to use the choice for all cookies from this site on every restart.


Expected results:

Firefox should not ask again for cookie settings for sites that have been accepted or denied via "use my choice for all cookies from this site"
If you have "Clear History when Firefox closes" box ticked in this dialog:
https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-24-9a2697.png

Is the "Site Preferences" box ticked in this dialog that opens when you click the "Settings" button?
https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-43-c0b014.png
Flags: needinfo?(m.richartz)
The "Clear History when Firefox closes" was and is unchecked. Therefore the "Settings …" button is greyed out.
When I turn it on for a moment then in the Settings box "Site preferences" is unchecked. (I unchecked "Clear History" again.)
Flags: needinfo?(m.richartz)
More detail on this has come to light in bug 814554
Depends on: 814554
Confirming now that bug 814554 is confirmed.
Leaving this open for others doing a quick search of bugzilla to avoid many duplicates, even though that bug being fixed will fix this one. I'm not opposed to this being duped to bug 814554 though if someone feels it should be.
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Can you still reproduce the issue on FF 17.0.1 ?
(In reply to Paul Silaghi [QA] from comment #5)
> Can you still reproduce the issue on FF 17.0.1 ?

The issue is gone as of 17.0.1. Congrats to everybody involved to nail it down.
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 814554
Resolution: --- → DUPLICATE
Duplicate of bug: 814554
You need to log in before you can comment on or make changes to this bug.