Segmentation fault quitting Mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Fred Richardson, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9+) Gecko/20010514
BuildID:    2001051415

I'm running on a RedHat 7.2 system.

I ran the debugger on mozilla (no debugging symbols) and I got this:

Program received signal SIGSEGV, Segmentation fault.
0x400d5879 in nsCOMPtr_base::~nsCOMPtr_base () at eval.c:41
41
eval.c: No such file or directory.
	in eval.c

I also ran `strace' and here are the last few lines:

gettimeofday({990114343, 830594}, NULL) = 0
ioctl(8, FIONREAD, [32])                = 0
read(8, "\2\30\376\v\226\353i\2071\0\0\0\272\0\340\1\0\0\0\0\211"..., 32) = 32
ioctl(8, FIONREAD, [0])                 = 0
access("/usr/lib/mozilla/res/builtin/userHTMLBindings.xml", F_OK) = -1 ENOENT
(No such file or directory)
munmap(0x40ef8000, 269552)              = 0
munmap(0x40f4a000, 270224)              = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++


Reproducible: Always
Steps to Reproduce:
1.Run mozilla
2.quit


Actual Results:  Registering plugin 0 for: "*","All types",".*"
Registering plugin 0 for: "application/x-shockwave-flash","Shockwave Flash","swf"
Registering plugin 1 for: "application/futuresplash","FutureSplash
Player","spl"Registering plugin 0 for: "video/mpeg"," MPEG animation"," mpeg,
mpg, mpe"
Registering plugin 1 for: "video/x-mpeg"," MPEG animation"," mpeg, mpg, mpe"
Registering plugin 2 for: "video/quicktime"," Quicktime animation"," mov,qt"
Registering plugin 3 for: "video/x-quicktime"," Quicktime animation"," mov,qt"
Registering plugin 4 for: "video/dl"," DL animation"," dl"
Registering plugin 5 for: "video/x-dl"," DL animation"," dl"
Registering plugin 6 for: "video/sgi-movie"," SGI animation"," movie,movi,mv"
Registering plugin 7 for: "video/x-sgi-movie"," SGI animation"," movie,movi,mv"
Registering plugin 8 for: "video/anim"," IFF animation","
iff,anim5,anim3,anim7"Registering plugin 9 for: "video/x-anim"," IFF
animation"," iff,anim5,anim3,anim7"
Registering plugin 10 for: "video/msvideo"," AVI animation"," avi"
Registering plugin 11 for: "video/x-msvideo"," AVI animation"," avi"
Registering plugin 12 for: "video/fli"," FLI animation"," fli, flc"
Registering plugin 13 for: "video/x-fli"," FLI animation"," fli, flc"
Registering plugin 14 for: "audio/midi"," MIDI audio file"," midi,mid"
Registering plugin 15 for: "audio/x-midi"," MIDI audio file"," midi,mid"

Registering plugin 16 for: "audio/mod"," Soundracker audio Module"," mod"
Registering plugin 17 for: "audio/x-mod"," Soundracker audio Module"," mod"
Registering plugin 18 for: "audio/mpeg2"," MPEG audio"," mp2"
Registering plugin 19 for: "audio/x-mpeg2"," MPEG audio"," mp2"
Registering plugin 20 for: "audio/mpeg3"," MPEG audio"," mp3"
Registering plugin 21 for: "audio/x-mpeg3"," MPEG audio"," mp3"
Registering plugin 22 for: "audio/mpeg"," MPEG audio"," mpa,abs,mpega"
Registering plugin 23 for: "audio/x-mpeg"," MPEG audio"," mpa,abs,mpega"
Registering plugin 24 for: "audio/basic"," Basic audio file"," au,snd"
Registering plugin 25 for: "audio/x-basic"," Basic audio file"," au,snd"
Registering plugin 26 for: "audio/wav","Microsoft wave file","wav"
Registering plugin 27 for: "audio/x-wav","Microsoft wave file","wav"
Registering plugin 28 for: "image/tiff"," TIFF image"," tiff,tif"
Registering plugin 29 for: "image/x-tiff"," TIFF image"," tiff,tif"
Registering plugin 30 for: "image/sun-raster"," SUN raster image"," rs"
Registering plugin 31 for: "image/x-sun-raster"," SUN raster image"," rs"
Registering plugin 32 for: "audio/mpeg-url"," MPEG music resource locator"," m3u"
Registering plugin 33 for: "audio/x-mpeg-url"," MPEG music resource locator"," m3u"
Registering plugin 34 for: "audio/mpegurl"," MPEG music resource locator","
m3u"Registering plugin 35 for: "audio/x-mpegurl"," MPEG music resource
locator"," m3u"
Registering plugin 0 for: "application/x-java-vm","Java(tm) Plug-in",""
Registering plugin 1 for: "application/x-java-applet","Java(tm) Plug-in",""
Registering plugin 2 for: "application/x-java-applet;version=1.1","Java(tm)
Plug-in",""
Registering plugin 3 for: "application/x-java-applet;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 4 for: "application/x-java-applet;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 5 for: "application/x-java-applet;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 6 for: "application/x-java-applet;version=1.2","Java(tm)
Plug-in",""
Registering plugin 7 for: "application/x-java-applet;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 8 for: "application/x-java-applet;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 9 for: "application/x-java-applet;version=1.3","Java(tm)
Plug-in",""
Registering plugin 10 for:
"application/x-java-applet;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Registering plugin 11 for: "application/x-java-bean","Java(tm) Plug-in",""
Registering plugin 12 for: "application/x-java-bean;version=1.1","Java(tm)
Plug-in",""
Registering plugin 13 for: "application/x-java-bean;version=1.1.1","Java(tm)
Plug-in",""
Registering plugin 14 for: "application/x-java-bean;version=1.1.2","Java(tm)
Plug-in",""
Registering plugin 15 for: "application/x-java-bean;version=1.1.3","Java(tm)
Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for: "application/x-java-bean;version=1.2.1","Java(tm)
Plug-in",""
Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""
Document http://www.d4m.bbn.com/~frichard loaded successfully
Document http://www.mozilla.org/ loaded successfully
Error loading URL http://www.mozilla.org/quality/help/bug-form.html :
2152398850Document http://www.mozilla.org/quality/help/bugzilla-helper.html
loaded successfully
Segmentation fault


Expected Results:  Not segfaulted

Comment 1

17 years ago
Reporter,

Please try a newer build.  A number of crasher bugs have been worked out since 
your build.

Everything WFM so far on build 2001051704 on Win2k (SP2)

jake

Updated

17 years ago
Keywords: crash

Comment 2

17 years ago
not seeing that with my cvs linux from yesterday, please try a newer build.

Comment 3

17 years ago
Works for me on linux build 2001060811. Resolving worksforme based on previous
comments.
Reporter, if this still crashes for you using a newer build, please feel free to
reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.