ClearType configuration is sub optimal (update from firefox 16 to 17)

RESOLVED DUPLICATE of bug 814101

Status

()

RESOLVED DUPLICATE of bug 814101
6 years ago
4 years ago

People

(Reporter: alexander.stohr, Unassigned)

Tracking

17 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

downloaded firefox 17 using the update process.
after restart it appeared to me that fonts do look somewhat blurred.
i first supposed some anti-aliasing was in place
but after some research it turned out that the hardware acclereration is on
and thus the direct2d interface is most probably used for font rendering.
disabling it made previously customed font style re-appear.

going a bit further to this page using MSIE:
http://www.microsoft.com/typography/ClearTypeFAQ.mspx
the first answer in the FAQ tells about tuning options for clear type...

i was able to tune my ClearType settings and significantly enhance my font experience in the samples.
as running on windows vista i gave the power toy utility a try (and windows complaint about this tool not absolutely beeing compatible with my OS version but only with XP - just ignored it.)
the previous wizard settings already were quite good, so no further improvements were achievable.

turning Firefox hardware accellaration on again now showed a much better result than before.
i am still unsure if i want to keep accelleration or switch back to unaccelerated but 100% pixel exact and thus definitely maximum sharpness fonts. if you experience a similar problem this should guide you to resolve it.



Expected results:

firefox should offer better methods for controlling font rendering.
launching the clear type configuration programs might be a solution.
other solutions might be the option for the user to use general accelleration but still dont use clear type - e.g. some options that will control font rendering.
(Reporter)

Comment 1

6 years ago
seems the underlying effects and systems were already described: Bug 574976 

at present i assume ClearType was off - but some other service provided anti-aliasing or clear type alike "smoothing".

seemingly thunderbird was affected as well by enabling cleartype and it does not look that good with it, so what was the solution for one application was a step back for some other application.

maybe the answer is the ability for better control on a per-application base.
(Reporter)

Comment 2

6 years ago
Bug 490809 seems to propose a simple solution that would fit the problem.
still there might be more good options around.
so preferebly let the user decide what looks best on his very own screen (LCD or CRT or some beamer).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 814101
You need to log in before you can comment on or make changes to this bug.