Last Comment Bug 814219 - nsMovemailService doesn't build with external linkage anymore
: nsMovemailService doesn't build with external linkage anymore
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Movemail (show other bugs)
: unspecified
: x86_64 Linux
: -- critical (vote)
: Thunderbird 20.0
Assigned To: Karsten Düsterloh
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 15:40 PST by Karsten Düsterloh
Modified: 2013-03-08 02:01 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
include missing header (787 bytes, patch)
2012-11-21 15:40 PST, Karsten Düsterloh
neil: review+
Details | Diff | Review

Description Karsten Düsterloh 2012-11-21 15:40:05 PST
Created attachment 684213 [details] [diff] [review]
include missing header

Building with --enable-incomplete-external-linkage now fails:

In file included from /home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp:18:0:
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.h:31:3: error: ‘nsCOMPtr’ does not name a type
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp: In member function ‘void nsMovemailService::Error(int32_t, const PRUnichar**, uint32_t)’:
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp:101:8: error: ‘mMsgWindow’ was not declared in this scope
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp:104:17: error: ‘mMsgWindow’ was not declared in this scope
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp: In member function ‘virtual nsresult nsMovemailService::GetNewMail(nsIMsgWindow*, nsIUrlListener*, nsIMsgFolder*, nsIMovemailIncomingServer*, nsIURI**)’:
/home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/nsMovemailService.cpp:360:3: error: ‘mMsgWindow’ was not declared in this scope
make[2]: *** [nsMovemailService.o] Error 1
Comment 1 neil@parkwaycc.co.uk 2012-11-22 00:34:27 PST
(In reply to Karsten Düsterloh from comment #0)
> /home/kd/projects/mozilla/mozilla.org/src/trunk/mailnews/local/src/
> nsMovemailService.h:31:3: error: ‘nsCOMPtr’ does not name a type
Since the error is in the .h file, why did you patch the .cpp file?
Comment 2 Karsten Düsterloh 2012-11-22 02:17:26 PST
(In reply to neil@parkwaycc.co.uk from comment #1)
> Since the error is in the .h file, why did you patch the .cpp file?

Huh? But I didn't!?!
Comment 3 neil@parkwaycc.co.uk 2012-11-22 02:21:45 PST
Comment on attachment 684213 [details] [diff] [review]
include missing header

Oops, engage brain before typing...
Comment 4 Mark Banner (:standard8) 2012-11-22 02:49:31 PST
Comment on attachment 684213 [details] [diff] [review]
include missing header

This doesn't need sr.
Comment 5 Karsten Düsterloh 2012-11-22 11:04:21 PST
https://hg.mozilla.org/comm-central/rev/44d69d59d729

Note You need to log in before you can comment on or make changes to this bug.