mobile.twitter.com does not allow user to select text while composing a text (because -moz-user-select:none)

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
TL;DR? Twitter should use "-moz-user-select:-moz-none", not "-moz-user-select:none".

STR:
1. With Firefox for Android or desktop, load https://mobile.twitter.com/compose/tweet
2. Enter some text
3. Try to select the text

RESULT:
You cannot select the text or insert new text.

The problem is that mobile.twitter.com's CSS specifies "-moz-user-select:none", which regrettably behaves differently from "-webkit-user-select:none". Twitter should use "-moz-user-select:-moz-none" to get the WebKit-like behavior:

https://developer.mozilla.org/en-US/docs/CSS/user-select
(Reporter)

Updated

5 years ago
Blocks: 799029
(Reporter)

Comment 1

5 years ago
Block twitter.com meta bug 763510
Blocks: 763510
(Reporter)

Updated

5 years ago
Depends on: 816298
Duplicate of this bug: 829544
Duplicate of this bug: 833621

Updated

5 years ago
Blocks: 869205

Updated

5 years ago
No longer blocks: 869205

Updated

5 years ago
Duplicate of this bug: 868849

Updated

5 years ago
Blocks: 869205
Fix is ready and will be deployed in the next couple of days.

Updated

5 years ago
Summary: mobile.twitter.com does not allow user to select text while composing a text (because -moz-user-select:none) → (Android) mobile.twitter.com does not allow user to select text while composing a text (because -moz-user-select:none)
The title change here is incorrect. See one of the dupes here - this affects all platforms.
OS: Android → All
Summary: (Android) mobile.twitter.com does not allow user to select text while composing a text (because -moz-user-select:none) → mobile.twitter.com does not allow user to select text while composing a text (because -moz-user-select:none)
Seems this fix is rolled out (tested on desktop) - Karl or Lawrence, could you verify?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Or does it just seem fixed to me because a fix for 816298 is in my Firefox 23?)
I see this styling:

.userselect {
    -moz-user-select: text;
}

so it seems RESOLVED FIXED is correct :)
You need to log in before you can comment on or make changes to this bug.