Closed Bug 814330 Opened 10 years ago Closed 7 years ago

crash in nsOfflineCacheDevice::ChooseApplicationCache

Categories

(Core :: Networking: Cache, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1237782
Tracking Status
firefox19 --- affected
firefox20 --- affected
firefox21 --- affected
firefox22 --- affected
firefox24 --- affected
firefox25 --- affected

People

(Reporter: ioana.chiorean, Assigned: mayhemer)

References

Details

(Keywords: crash, Whiteboard: [native-crash][b2g-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ca342a47-2639-4105-a382-f21f22121122 .

Steps:
1. Open external link from Twiiter/ TweetDeck
2. Tap URL bar

I was unable to reproducible 
============================================================= 
0 	libxul.so 	nsOfflineCacheDevice::ChooseApplicationCache 	nsDiskCacheDeviceSQL.cpp:2474
1 	libxul.so 	nsApplicationCacheService::ChooseApplicationCache 	nsApplicationCacheService.cpp:147
2 	libxul.so 	mozilla::net::nsHttpChannel::OpenCacheEntry 	nsHttpChannel.cpp:2354
3 	libxul.so 	mozilla::net::nsHttpChannel::Connect 	nsHttpChannel.cpp:416
4 	libxul.so 	mozilla::net::nsHttpChannel::BeginConnect 	nsHttpChannel.cpp:4437
5 	libxul.so 	mozilla::net::nsHttpChannel::OnProxyAvailable 	nsHttpChannel.cpp:4515
6 	libxul.so 	nsAsyncResolveRequest::DoCallback 	nsProtocolProxyService.cpp:240
7 	libxul.so 	nsAsyncResolveRequest::Run 	nsProtocolProxyService.cpp:140
8 	libxul.so 	nsThread::ProcessNextEvent 	nsThread.cpp:627
9 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:221
10 	libxul.so 	nsThread::Shutdown 	nsThread.cpp:474
11 	libxul.so 	nsCacheService::Shutdown 	nsCacheService.cpp:1269
12 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	nsAppShell.cpp:453
13 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	nsBaseAppShell.cpp:139
14 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	nsBaseAppShell.cpp:280
15 	libxul.so 	nsThread::ProcessNextEvent 	nsThread.cpp:600
16 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:221
17 	libxul.so 	mozilla::ipc::MessagePump::Run 	MessagePump.cpp:82
18 	libxul.so 	MessageLoop::RunInternal 	message_loop.cc:215
19 	libxul.so 	MessageLoop::Run 	message_loop.cc:208
20 	libxul.so 	nsBaseAppShell::Run 	nsBaseAppShell.cpp:163
21 	libxul.so 	nsAppStartup::Run 	nsAppStartup.cpp:290
22 	libxul.so 	XREMain::XRE_mainRun 	nsAppRunner.cpp:3823
23 	libxul.so 	XREMain::XRE_main 	nsAppRunner.cpp:3890
24 	libxul.so 	XRE_main 	nsAppRunner.cpp:4084
25 	libxul.so 	GeckoStart 	nsAndroidStartup.cpp:73
26 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	APKOpen.cpp:1005
27 	libdvm.so 	libdvm.so@0x1de32 	
28 	dalvik-heap (deleted) 	dalvik-heap @0xae0846 	
29 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x18cc1f 	
30 	libdvm.so 	libdvm.so@0x4d085 	
31 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x18cc1d 	
32 	libmozglue.so 	mozilla::RefPtr<Zip>::~RefPtr 	RefPtr.h:109
33 		@0x5c21e0ae 	
34 	libc.so 	libc.so@0x1556f 	
35 	libc.so 	libc.so@0x15537 	
36 	libc.so 	libc.so@0x16d43 	
37 	libdvm.so 	libdvm.so@0x4f3f5 	
38 	core.odex 	core.odex@0x1ea19f 	
39 	dalvik-heap (deleted) 	dalvik-heap @0xc8165e 	
40 	dalvik-heap (deleted) 	dalvik-heap @0xc8165e 	
41 	libdvm.so 	libdvm.so@0x99d5a 	
42 	dalvik-heap (deleted) 	dalvik-heap @0xc8165e 	
43 	dalvik-heap (deleted) 	dalvik-heap @0x1446 	
44 	libdvm.so 	libdvm.so@0x99d5a 	
45 	dalvik-heap (deleted) 	dalvik-heap @0xc8165e 	
46 	libdvm.so 	libdvm.so@0x99d5a 	
47 	dalvik-heap (deleted) 	dalvik-heap @0xc8165e 	
48 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2b175a 	
49 	dalvik-heap (deleted) 	dalvik-heap @0xae0846 	
50 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2b1746 	
51 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x1a6b94 	
52 	libdvm.so 	libdvm.so@0x4f2fb 	
53 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2b1746 	
54 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2b1746 	
55 	libdvm.so 	libdvm.so@0x4cef7 	
56 	dalvik-heap (deleted) 	dalvik-heap @0xae0846 	
57 	libdvm.so 	libdvm.so@0x4f19f 	
58 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2b1746 	
59 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0xd85b6 	
60 	dalvik-heap (deleted) 	dalvik-heap @0xae0846 	
61 	libdvm.so 	libdvm.so@0x1dfbe 	
62 	libdvm.so 	libdvm.so@0x27262 	
63 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2f1416 	
64 	libdvm.so 	libdvm.so@0x2bb6a 	
65 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2f1416 	
66 	dalvik-heap (deleted) 	dalvik-heap @0xc0c51e 	
67 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x18c6a0 	
68 	libdvm.so 	libdvm.so@0x5f7f3 	
69 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2f1416 	
70 	dalvik-heap (deleted) 	dalvik-heap @0xc0c51e 	
71 	libdvm.so 	libdvm.so@0x5f81d 	
72 	libdvm.so 	libdvm.so@0x543d5 	
73 	libdvm.so 	libdvm.so@0x54333 	
74 	libdvm.so 	libdvm.so@0x54333 	
75 	libc.so 	libc.so@0x12bb2 	
76 	libc.so 	libc.so@0x1230a
Component: General → Networking: Cache
Product: Firefox for Android → Core
Whiteboard: [native-crash]
Version: unspecified → Trunk
Crash Signature: [@ nsOfflineCacheDevice::ChooseApplicationCache(nsACString_internal const&, nsILoadContext*, nsIApplicationCache**)] → [@ nsOfflineCacheDevice::ChooseApplicationCache(nsACString_internal const&, nsILoadContext*, nsIApplicationCache**) ]
Looks like we are missing some kind of "is initialized" check.

I'll take a look.
Assignee: nobody → honzab.moz
I may fix this as part of work on bug 822833.

This is a very low frequency crash.
Whiteboard: [native-crash] → [native-crash][b2g-crash]
Crash Signature: [@ nsOfflineCacheDevice::ChooseApplicationCache(nsACString_internal const&, nsILoadContext*, nsIApplicationCache**) ] → [@ nsOfflineCacheDevice::ChooseApplicationCache(nsACString_internal const&, nsILoadContext*, nsIApplicationCache**) ] [@ nsOfflineCacheDevice::ChooseApplicationCache ]
Duplicate of this bug: 901557
Depends on: 1237782
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: 1237782
Resolution: --- → DUPLICATE
Duplicate of bug: 1237782
You need to log in before you can comment on or make changes to this bug.