Right mouse button clicks sent to content and chrome

VERIFIED DUPLICATE of bug 71705

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 71705
17 years ago
17 years ago

People

(Reporter: Adam Lock, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When you load the URL and right mouse button click on the "display on desktop" 
link, the onmouseclick handler attached to the link opens a popup window and the 
chrome displays a context menu.

Shouldn't we do just one or the other? Should we swallow right-mouse button 
events while over content like IE does?

Comment 1

17 years ago
I think this pretty much a dup of bug 71705

Lots of discussion there about the right click triggering the onClick handler

Jake
(Assignee)

Comment 2

17 years ago
Agreed dupe.

*** This bug has been marked as a duplicate of 71705 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verifying dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.