RTL in <title> gives an incorrect window title

RESOLVED DUPLICATE of bug 814030

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 814030
5 years ago
5 years ago

People

(Reporter: Dan Wolff, Unassigned)

Tracking

({rtl})

18 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
0. &#x202e; is the RIGHT-TO-LEFT OVERRIDE char (RLO)
1. Write an HTML page with "<title>RTL: &#x202e; Hello there</title>"
2. Open the HTML page and note the title in the tabbar

Actual result:
1. The window title does not reset the RLO: the title shown is "RTL: aroruA - ereht olleH"

Expected result:
1. The window title resets the RLO: the title should display as "RTL: ereht olleH - Aurora"

Related to bug 814347, title display in the tabbar. See also attachments of that bug:
Example HTML file: https://bug814347.bugzilla.mozilla.org/attachment.cgi?id=684352
Screenshot: https://bug814347.bugzilla.mozilla.org/attachment.cgi?id=684353

Comment 1

5 years ago
Created attachment 696643 [details]
snapshot of RTL override working for a given web-site

[testday-20121221] edwardb

Visited this website, and, well, the results are obvious.
Bug status: RESOLVED, INVALID

Comment 2

5 years ago
[testday-20121221] edwardb

On second observation, it appears the bug remains, according to Dan in the first posting.

It is unclear the design of Firefox in this matter.  Whether the name of the browser being used should be reversed along with the Title...

For this, we need to consult a user whose language goes from right-to-left, such as Hebrew.  Ask him/her if it makes sense for the name of the browser used to also be read from right-to-left along with the Title of the web page that is forced to read right-to-left.

Bug status: NEW

Comment 3

5 years ago
Comment on attachment 696643 [details]
snapshot of RTL override working for a given web-site

Dan suggested that ONLY the Title be forced to read right-to-left when that RTL code is used in <title> </title> .
(Reporter)

Comment 4

5 years ago
Exactly. It might make sense to move the "Mozilla Firefox" part in the case of an RTL document ("Mozilla Firefox - xxx" instead of "xxx - Mozilla Firefox"), but I can't imagine anybody wanting to see "xoferiF allizoM".

Comment 5

5 years ago
See also: http://xkcd.com/1137/
Keywords: rtl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814030
You need to log in before you can comment on or make changes to this bug.