[PP] Post to newsgroup crashes on Send.

VERIFIED FIXED in M7

Status

MailNews Core
Backend
P1
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac System 8.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using 1999061408 m7 on Mac OS 8.51
Does not happen using jun14 builds with linux and NT 4.0

Crash upon Send when posting to newsgroup.  Profile set up for only
news.mozilla.org, not trying to post to some other server.

1.  Using multiple account prefs, only news server is news.mozilla.org with
netscape.test subscribed and its messages displayed in seamonkey.
2.  New Message.
    No mail addressee specified, just posting to newsgroup.
    In newsgroup header line, type netscape.test.
    Type a subject then a few letters in the message body (no html attributes).
3.  Click Send button.
Result:  Crash occurs.

Talkback tracking ID FNR10Ivv, incident 9965105:
(Getting a timeout when clicking on the incident report link.  Will put trace in
comments later.)
(Reporter)

Updated

19 years ago
QA Contact: lchiang → scurtis

Updated

19 years ago
Blocks: 6657

Updated

19 years ago
Blocks: 6655

Updated

19 years ago
Blocks: 7995
(Reporter)

Updated

19 years ago
Priority: P3 → P1
(Reporter)

Comment 1

19 years ago
Still waiting to successfully contact the talkback server for incident report.
Changed priority to p1.
(Reporter)

Comment 2

19 years ago
Finally! Talkback report:
Call Stack:    (Signature = 0x7b6f7b6c 26588e2e)

   0x7b6f7b6c
   MsgCompose.shlb + 0x87cc (0x0b530e8c)
   MsgCompose.shlb + 0x7960 (0x0b530020)
   MsgCompose.shlb + 0x68a4 (0x0b52ef64)
   MsgCompose.shlb + 0x1481c (0x0b53cedc)
   mailnews.shlb + 0x3b18 (0x0b503dd8)
   mailnews.shlb + 0x3c2c (0x0b503eec)
   MsgNews.shlb + 0x16308 (0x0af74848)
   MsgNews.shlb + 0x12b10 (0x0af71050)
   MsgNews.shlb + 0x2afcc (0x0af8950c)
   nsStreamListenerProxy::OnDataAvailable() [nsNetThread.cpp, line 815]
   stub_put_block()                         [nsStubContext.cpp, line 834]
   net_MemCacheWrite()                      [mkmemcac.c, line 660]
   net_flush_sockstub_data()                [sockstub.cpp, line 433]
   net_ProcessSockStub()                    [sockstub.cpp, line 544]
   NET_ProcessNet()                         [mkgeturl.c, line 3351]

Comment 3

19 years ago
In the June 15 Mac Seamonkey respin build (1999061514), it appears the send to
newsgroup "netscape.test" no longer occurs.  I was successful in posting a couple
of test message and did not crash.

Leaving bug open for second opinion.

Comment 4

19 years ago
Works for me, 6_16 Mac build.

Comment 5

19 years ago
lchiang...can we confirm that this works for Jun18 build.  If not, and theres a
crash, can we release note for M7?

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M7

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Marking fixed since this is working in M7.

Comment 7

19 years ago
fyi,
I was able to post to netscape.test newsgroup using the Mac June 16, 17, and 18
Seamonkey builds.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.