Closed Bug 814528 Opened 9 years ago Closed 9 years ago

Bookmarks deleted from history sidebar still appear in awesomebar results

Categories

(Firefox :: Untriaged, defect)

16 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 773982

People

(Reporter: dreadnaut, Unassigned)

Details

Attachments

(1 file)

Attached image bookmarks.png
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

Starting from Fx 16 entries I delete from history (usually through the sidebar) sometimes still appear among the awesomebar results. These items are not bookmarked.

I noticed because I delete all entries containing "google" every couple of days, but recently they still pollute the awesomebar. It seems to happen more often with *redirects*.

Reproduced with a clean profile in Firefox 16.0.2 and 17.0.

- Visit a redirecting url, e.g. m.engadget.com or www.google.com outside the US
- You will be redirected to www.engadget.com or www.google.<your country>
- Open the history sidebar and delete the entry
- Navigate away from the page
- Start typing the url above, and it appears as a AwsBar suggestion



Actual results:

The awesomebar is still listing items which I have delete from history and are not bookmarked otherwise.


Expected results:

Ghosts of items gone from history should not linger around.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 773982
You need to log in before you can comment on or make changes to this bug.