Online Editor SPAW not shown due to UA sniffing in FF17

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: baltic, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

Calling Sometra :

http://www.spaweditor.com/en/disp.php/en_products/en_spaw/en_spaw_demo

Calling other pages, which use the WYSIWYG editor



Actual results:

Instead of the editor only a textarea is shown. (WIN7 and MAC)

Other main browsers work ok.


Expected results:

WYSIWYG editor should be shown.
The page is doing Useragent sniffing and it fails because our Useragent string format changed.

an example for the old User agent string
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.8) Gecko/20100101 Firefox/10.0.8
and the new one:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Blocks: 588909
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Javascript issue - Online Editor SPAW not shown since V. 17.0 → Online Editor SPAW not shown due to UA sniffing in FF17

Comment 2

5 years ago
Duplicate of bug 789023
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789023
(Reporter)

Comment 4

5 years ago
sorry to bother, but with v 17.0.1 again -> no spaw indication.

we fixed the "sniffing" stuff with 17.0.0. what's new now?

any idea would help!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

5 years ago
(In reply to baltic from comment #4)

> we fixed the "sniffing" stuff with 17.0.0. what's new now?

The UA changes in Gecko 17 (Firefox 17) were reverted in version 17.0.1 because of various incompatibilities.
See bug 588909 and it's depending bugs and bug 815743 for details.

old:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.8) Gecko/20100101 Firefox/10.0.8

new (Firefox 17.0):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

but reverted to the old style now with Firefox 17.0.1:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0


Please note that proper detection of the Gecko version all time was searching
for the "rv:" value.

Sorry for your inconvenience.
Hello,

I have seen that spaweditor is no more actual and the last version was working in firefox.
can you please give us an update? is this error still valid from your site?

thank you for your help.
Flags: needinfo?(ww)
no feedback from reporter and not reproduceable.
so this bug-report will be closed.

please feel free to reopen this report if you have new information to reproduce.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago3 years ago
Flags: needinfo?(ww)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.