Closed Bug 814531 Opened 9 years ago Closed 9 years ago

Enable WebRTC crashtests on mozilla-central

Categories

(Core :: WebRTC, defect, P1)

19 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 826044

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Whiteboard: [WebRTC],[blocking-webrtc+])

Attachments

(1 file)

We want to enable the crashtests on mozilla-central. But before we can do that we have to fix the remaining memory leaks and the assertion for mozRTCPeerConnection in IPC mode. See the dependent bugs.
Keywords: meta
Priority: -- → P1
Summary: Enable WebRTC crashtests on mozilla-central → [meta] Enable WebRTC crashtests on mozilla-central
Whiteboard: [WebRTC] → [WebRTC][webrtc-blocking+]
Whiteboard: [WebRTC][webrtc-blocking+] → [WebRTC],[webrtc-blocking+]
Whiteboard: [WebRTC],[webrtc-blocking+] → [WebRTC],[blocking-webrtc+]
This probably doesn't make sense to have as a meta bug actually given that there would be a patch here to pref on crashtests.

The leak dependencies are fixed now. What's left to do here in order to pref these on in central with leak checking?
Flags: needinfo?(hskupin)
Keywords: meta
Summary: [meta] Enable WebRTC crashtests on mozilla-central → Enable WebRTC crashtests on mozilla-central
-> henrik

I think we're ready to try enabling crashtests
Assignee: nobody → hskupin
I pushed this to try with leak checking enabled for webrtc crashtests:
https://tbpl.mozilla.org/?tree=Try&rev=1bd6312b7f38
Status: NEW → ASSIGNED
Flags: needinfo?(hskupin)
Try server results are all green. I'm going to upload a patch in a minute to enable crashtests by default on m-c.
Attached patch Patch v1Splinter Review
Please keep in mind that when this lands we will have to backout the patch on bug 801682 first before the next merge to Alder.
Attachment #697001 - Flags: review?(rjesup)
Attachment #697001 - Flags: review?(rjesup) → review+
We have lots of leaks with this push. We should figure out what's wrong with those. I will investigate soon. For now I have backed out the patch:

ssh://hg.mozilla.org/integration/mozilla-inbound/
Backed out for leaks:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a5fee86dec9e

https://hg.mozilla.org/integration/mozilla-inbound/rev/4f5a049ce9c9

Your try run seems to have alder csets in it, which is perhaps why it was green.
Depends on: 811764
Depends on: 826029
No longer depends on: 811764
Depends on: 826044
No longer depends on: 826044
Any remaining issues are marked as dependencies on Bug 826044
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826044
You need to log in before you can comment on or make changes to this bug.