partial page download marked as done (v0.9)

RESOLVED WORKSFORME

Status

()

Core
Networking
P3
major
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Avi Rappoport, Unassigned)

Tracking

({verifyme})

Trunk
Future
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have semi-consistent problems with certain pages, including the mozilla.org
home page and As The Apple Turns (currently at 64.67.147.234).  They get partway
displayed, and then stop.  Sometimes reloading the page will get more done,
other times it won't.  But the bottom status bar marks it as "Done".  This makes
mozilla almost unusable for me.

I have a screenshot and copy of my view page source.  Since I see no way to
attach them, I'm storing them at
<http://www.searchtools.com/pub/mozilla-org-partial.gif> and
<http://www.searchtools.com/pub/mozilla-org-partial.txt>.

Comment 1

17 years ago
I'm seeing behavior similar to this on Linux.  Build ID: 2001061518.

Fairly regularly, pages will only partially load, but the throbber stops and
the status bar will claim that the document load is done.

When I hit reload, it goes back out to the network, the rest of the page is
loaded and rendered.

There doesn't seem to be a particular pattern to when this happens.

Comment 2

17 years ago
Similar problem with http://www.itn.co.uk

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010616
BuildID: 2001061606


Reproducible: Always
Steps to Reproduce:
1.open http://www.itn.co.uk
2.(throbber stops and the status bar will claim that the document load)
3.There will be no change you will still see your current page
4. Note: however, if you do a view source you will see that some (all?)
of the html of the new page has been downloaded
5. Hitting reload does not fix this problem
6. Hitting go (or enter on the url) DOES cause a full page to appear.

(unfortunately, my ISP has some problems with its DNS, which may be the
root cause of this problem, for me. But, I can reproduce it every time, if
some one else can reproduce this problem then I know it not just my setup)



Comment 3

17 years ago
over to Networking for triage. I think there are similar bugs already know.
(BTW, there is a way to make attachments to bugs. Under the Keywords:  text
field us a link titled "Create a new attachment".)
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → benc
(Reporter)

Comment 4

17 years ago
I'm having the same problems with Netscape 6.1 PR 1.  No such problems with NN 
4.72 or IE 5.  I did a watch on the stream and it looks like this:

Receive data (896 bytes) on stream 32.
>0000A15F> <TABLE BORDER="0"><TR><TD BGCOLOR="#000000" VALIGN="TOP"> 
>0000A199> <TABLE BORDER="0" CELLPADDING="10" CELLSPACING="0" WIDTH="100%" 
>0000A1D9> BGCOLOR="lightyellow"> 
>0000A1F0> <TR><TD> 
>0000A1F9> This is <B>Bugzilla</B>: the Mozilla bug system.  For 
>0000A22F> more 
>0000A234> information about 
>0000A246> what Bugzilla is and what it can do, see 
>0000A26F> <A 
>0000A272> HREF=http://www.mozilla.org/>mozilla.org</A>'s 
>0000A2A1> <A 
>0000A2A4> HREF=http://www.mozilla.org/bugs/><B>bug pages</B></A>. 
>0000A2DC>  
>0000A2DD> <BR> 
>0000A2E2> <FORM METHOD=GET ACTION="show_bug.cgi"> 
>0000A30A> <TABLE width="100%"><TR><TD> 
>0000A327> Actions: 
>0000A330> </TD><TD VALIGN="middle" NOWRAP> 
>0000A351> <a href='enter_bug.cgi'>New</a> | <a href='query.cgi'>Query</a> 
>0000A391> | 
>0000A393>  <INPUT TYPE=SUBMIT VALUE="Find"> bug # <INPUT NAME=id 
>0000A3CA> SIZE=6> | <a href='reports.cgi'>Reports</a></TD><TD>&nbsp;</TD><
>0000A40A> TD valign=middle align=right> 
>0000A428>  <a href="createaccount.cgi"><NOBR>New account</NOBR></a> 
>0000A462>  | <NOBR><a href=query.cgi?GoAheadAndLogIn=1>Log in</a></NOBR></
>0000A4A2> TD></TR></FORM> 
>0000A4B2> </TABLE> 
>0000A4BB> </TD></TR></TABLE></TD></TR></TABLE>

Receive orderly release indication (T_ORDREL_IND = 132) on stream 32.

Comment 5

17 years ago
Marking NEW but pretty sure this is a dupe but its worth having someone look at
it just to make sure.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
WFM on Win 2k. Can a Mac person confirm this bug is still happening?
-> jtaylor
Assignee: neeti → jtaylor
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3

Comment 7

17 years ago
Retargeting. I need to know if this is still happening.
Keywords: qawanted
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 8

17 years ago
Ditto, same problem on Mozilla 0.9.2 (Build 2001062823).

Can't post examples, since I found the bug while developing internal pages. 
Pages load fully on IE and Netscape 4.x, but stop prematurely under Mozilla

***MAGIC NUMBER***
On the page where the effect is reproducable, it always dies after 16384
characters (i.e. 2^14)


Comment 9

17 years ago
**Workaround**
If you use HTTP/1.0, the bug seems to go away (at least for me)
Edit->Preferences->Debug->Networking->HTTP Version, set to "1.0"

Obviously, reliable performance under HTTP/1.1 would be better, but if you run
into this problem alot, this seems to work around it.
(Reporter)

Comment 10

17 years ago
I did some more checking and found that most of my problems involve
incompatibilities with the WebFree control panel
<http://www.falken.net/webfree/>.  Turning off all the ad-cleaning options makes
the pages show up properly (sigh).  I have reported the problem to the
programmer and hope he'll update for compatibility.  Thanks for the attention to
this problem!

Comment 11

17 years ago
Cleaning bug list ...
Assignee: jtaylor → neeti
Target Milestone: mozilla0.9.4 → Future

Comment 12

17 years ago
i have seen similar problems with 3 sites esp.: http://www.haayal.co.il
http://www.fisheye.co.il and http://www.dotkof.org  . the first two are on the
same server and use the same system (the programmer is Tal Cohen, tal@forum2.org
). all 3 are php based web site. this happens esp. when loading very long pages
(in the frst two) or following certain links (in the 3rd)

Comment 13

17 years ago
I see this all the time, as well. Not only when browsing to the outside world, but also 
when talking to an Apache 1.3.x server on my LAN. Most pages (including bugzilla) end 
up loading nothing at all, so I see the "fake" empty source when I view source on 
them. This happens with both Netscape 6.2 and Moz 1.0RC1.

Further, once I've gotten an incomplete page back, clearing the disk and memory 
cache don't force the page to reload, but seem to be get the exact same result if I 
try to reload the page.

Switching to HTTP 1.0 and turning off persistant connections seems to help. I get 
complete pages more frequently, but not always. It takes the percentage of 
incomplete pages down from about 90% to maybe 30%.

Comment 14

16 years ago
Exactly as comment 13 says Both Moz and Netscape 6.2 does this.  All other 
browsers on my Mac work fine on every page Moz and NS 6.2 fail to load.

Comment 15

16 years ago
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 17

14 years ago
Interesting that I can consistently reproduce this experience of "partial page
loads" when I go to a job board called FlipDog.   For example try visiting:

 http://flipdog.monster.com/js/jobdetails.html?ID=15300603&linkBack=index.html

The page will fill partially.

Then use the Windows Internet Explorer, and the page fully loads.

Is Flip Dog following MS Internet Explorer guidelines, and Mozilla may deviate
just a little.   It is different enough that some pages don't load fully, or
java scripts misbehave.   

    It is hard to job hunt this way.  

Updated

14 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 18

14 years ago
RESOLVED/WFM:
This bug is too old, and lacks any real data that we could give Darin.

I'm closing this bug. New problem to new bugs please. keep in mind that Darin
will want and http_log for any failures to load. A public web site and a problem
description for a current (daily build or most recent mileston) is also very
helpful.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: qawanted → verifyme
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.