Typing is not working for full flash sites

VERIFIED FIXED in Firefox 20

Status

defect
VERIFIED FIXED
7 years ago
Last year

People

(Reporter: xti, Assigned: jchen)

Tracking

20 Branch
Firefox 20
ARM
Android
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox19 affected, firefox20 verified)

Details

Attachments

(1 attachment)

Firefox 20.0a1 (2012-11-23)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Go to Settings > Plugins and set it to Enable
2. Go to http://www.zasmakujelegancji.pl/
3. Tap on any date fields and type any date

Expected result:
Typing is working fine on step 3.

Actual result:
No numbers can be filled in the date fields at step 3.
Since plugins only accept key events and not other IME events, this patch makes IMEs send key events when a plugin has the keyboard. It does this by using TYPE_NULL as the input type, and by switching to using BaseInputConnection which sends key events for us.
Attachment #694111 - Flags: review?(cpeterson)
Comment on attachment 694111 [details] [diff] [review]
Only use key events for plugins (v1)

Review of attachment 694111 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #694111 - Flags: review?(cpeterson) → review+
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: in-testsuite-
This had been landed in mozilla-inbound as:

http://hg.mozilla.org/integration/mozilla-inbound/rev/d6c5a0ec5757

then on to m-c in:

https://hg.mozilla.org/mozilla-central/rev/d6c5a0ec5757
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Firefox 20.0a1 (2013-01-03)
Device: Galaxy Nexus 
OS: Android 4.1.1 

I am able to enter numbers in all 3 data fields from http://www.zasmakujelegancji.pl 
Marking bug as Verified Fixed.
Status: RESOLVED → VERIFIED
Blocks: 822571
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.