Closed Bug 814822 Opened 7 years ago Closed 7 years ago

hal doesn't notify listeners when a wakelock is released due to child process dying

Categories

(Core :: Hardware Abstraction Layer (HAL), defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: dhylands, Assigned: kanru)

References

Details

Attachments

(1 file)

When a wakelock is released due to a child process crash, listeners which have registered with the nsIDOMMozPowerManager::AddWakeLockListener don't get notified (i.e. NotifyWakeLockChange doesn't get called)
nom'd since this blocks a blocking bug
Blocks: 806363
blocking-basecamp: --- → ?
Summary: hal doesn't notify listeners when a wkelock is released due to child process dying → hal doesn't notify listeners when a wakelock is released due to child process dying
Assignee: nobody → kchen
CountWakeLocks is moved before RemoveChildFromList. Also clear the sLockTable when wake lock count is 0. Assert that ModifyWakeLockInternal should only be called from main thread.
Attachment #685027 - Flags: review?(justin.lebar+bug)
Attachment #685027 - Flags: review?(justin.lebar+bug) → review+
I can confirm that this works for me now. Thanks
blocking-basecamp: ? → +
https://hg.mozilla.org/mozilla-central/rev/876bed348636
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Blocks: 785124
You need to log in before you can comment on or make changes to this bug.