background at http://k0s.org/pictures/specialfx/ no longer rendered

VERIFIED FIXED in Firefox 18

Status

()

defect
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: k0scist, Assigned: roc)

Tracking

({regression})

unspecified
mozilla20
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18+ verified, firefox19+ verified, firefox20+ verified)

Details

Attachments

(2 attachments)

This used to work in firefox and still works in chromium.  The background at http://k0s.org/pictures/specialfx/ as specified by

"""
      body {
           background-image: url('/pictures/specialfx/oilstainreflection2.jpg');
           background-repeat:no-repeat;
           background-position: right;
           background-attachment: fixed;
           background-size: 100% 100%;
      }
"""

is no longer rendered.  If I unset background-attachment: fixed; it does work, albeit I want background-attachment: fixed; for this page.  I'm not sure when this first stopped working.
Pretty unlikely to be DOM.

Jeff, can you find a regression range on nightlies?  Are you seeing this on Linux?  Because I see the background just fine on Mac, both with a current nightly and Firefox 17.
Component: DOM → Graphics
I can reproduce if HWA.
http://hg.mozilla.org/releases/mozilla-aurora/rev/4e0a8f234a6d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121124042012
and
http://hg.mozilla.org/mozilla-central/rev/3c67034ba39c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 ID:20121125030729

Steps to reproduce:
1. Disable HWA
2. Clear cache (if it is not a first attempt)
3. Restart Browser
4. Open http://k0s.org/pictures/specialfx/

Actual results:
Backgound is not rendered.
Reload page helps.

Expected results:
Background should be rendered at the first loading.


Regression wndow(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/58ebb638a7ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115172150
Bad:
http://hg.mozilla.org/mozilla-central/rev/a7ed19f7d21a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121116090659
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58ebb638a7ea&tochange=a7ed19f7d21a


Regression wndow(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/244493403e89
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115151651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2c2c6ddb6fe6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115163151
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=244493403e89&tochange=2c2c6ddb6fe6
Suspected: Bug 810470
Blocks: 810470
Keywords: regression
OS: Linux → All
err in comment #2
s/I can reproduce if HWA./I can reproduce if HWA off./
Posted file testcase
The background should turn green, but does not.

The problem is that the background image caching we do in nsDisplayCanvasBackground::Paint never invalidates the CachedBackgroundImage in response to the image loading, or being changed.
Assignee: nobody → roc
And nsIFrame::ClearDisplayItemCache is never called.
Posted patch fixSplinter Review
Attachment #685521 - Flags: review?(matt.woodrow)
Attachment #685521 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/12c06dee84cb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
confirmed: wfm :) thanks!
Comment on attachment 685521 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): DLBI
User impact if declined: Missing background image on Web site
Testing completed (on m-c, etc.): a few days on m-c
Risk to taking this patch (and alternatives if risky): Low risk. Just invalidates some cached stuff more often.
String or UUID changes made by this patch: None
Attachment #685521 - Flags: approval-mozilla-beta?
Attachment #685521 - Flags: approval-mozilla-aurora?
Attachment #685521 - Flags: approval-mozilla-beta?
Attachment #685521 - Flags: approval-mozilla-beta+
Attachment #685521 - Flags: approval-mozilla-aurora?
Attachment #685521 - Flags: approval-mozilla-aurora+
WFM for Windows 7 x64, Ubuntu x86 and Mac OS 10.8 for FF18b4.
Verified fixed on Firefox 18 beta 4. (especially because of the testcase attached in comment 4; while following the STR from comment 2, I couldn't see significant changes between a Nightly from 2012-11-16 and beta 4).

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121212073002
QA Contact: manuela.muntean
Verified fixed on Firefox 19 beta 2, based on the testcase provided in comment 4, with HWA on and off.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953
Fix is verified on FF20b5 too:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130313170052)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0(20130313170052)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.