Horizontal mousewheel control is broken

RESOLVED DUPLICATE of bug 786120

Status

()

defect
RESOLVED DUPLICATE of bug 786120
7 years ago
a month ago

People

(Reporter: fry.kun, Unassigned)

Tracking

({regression})

17 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119145849

Steps to reproduce:

Updated Firefox from 16 to 17


Actual results:

Existing settings for horizontal mousewheel action (history browse) no longer work. There is apparently no way to set up horizontal mousewheel actions to separate from vertical mousewheel actions, as per https://wiki.mozilla.org/Gecko:Mouse_Wheel_Scrolling#Mozilla_17_.28Firefox_17.29_or_later:
"You cannot specify different action to vertical wheel operation and horizontal wheel operation because both deltaX and deltaY values can be non-zero same time. So, specifying different action doesn't make sense. "


Expected results:

This needs to be user configurable
For me, most natural way of navigating is using vertial scroll to scroll within a page, and horizontal scroll (mousewheel tilt) to browse pages

Updated

7 years ago
Blocks: 719320
Component: Untriaged → Event Handling
Product: Firefox → Core

Comment 1

7 years ago
Maybe dupe of Bug 786120 if Bug 786120 Comment #8 is valid
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
No longer blocks: 719320
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786120
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.