Not showing installed apps in about:apps after fennec restarted

VERIFIED FIXED

Status

()

Firefox for Android
Web Apps
P2
normal
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: tetsuharu, Assigned: wesj)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox18 verified, firefox19 verified, firefox20 verified, fennec+)

Details

Environment:
* Nightly 20, http://hg.mozilla.org/mozilla-central/rev/597915b66059
* Android 4.0 (Xperia arc, ICS:sony build)

Step to reproduce:
1. Install app from Marketplace.
2. Restart Fennec.
3. Open about:apps

Result:
about:apps does not show any installed apps.

More info:
I found following log from adb logcat:
E/GeckoConsole [JavaScript Error: "TypeError: this._manifest is null" {file: "resource://gre/modules/AppUtils.jsm" line: 262}]

Updated

5 years ago
Assignee: nobody → wjohnston
tracking-fennec: --- → ?
status-firefox20: --- → affected
Keywords: regression, regressionwindow-wanted, reproducible, smoketest

Comment 1

5 years ago
The regression window for this issue is:

good build:
2012/10/25

bad build 
2012/10/26

possible push-log:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=972986c4f75e&tochange=5ecff3e46ed5
Keywords: regressionwindow-wanted

Updated

5 years ago
status-firefox19: --- → affected
I was able to reproduce this issue on the latest Beta build (Firefox 18.0b2). After doing some investigation, I noticed that this issue is not reproducing on the Nightly 18.

Even more, I've found that this issue is not reproducing on the Nightly from 10/23, but occurs on 10/24. Here is the regression range: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=48502b61a63e&tochange=93cc1ee94291

And on the Nightly from 10/25 works fine again, and as Paul mentioned in comment #1, on 10/26 occurs again.

I guess that the bug which cause this issue to occur, was uplifted to m-a since m-c was Firefox 19.

--
Device: Galaxy Tab 2 7"
OS: Android 4.0.4
status-firefox18: --- → affected
Also I tried to narrow down both regression-windows, but the last inbound builds are from 10/26.
tracking-fennec: ? → +
Priority: -- → P2

Updated

5 years ago
Duplicate of this bug: 816684
> tracking-fennec: ? → +
> Priority: -- → P2

We're not interested in fixing this regression from 17 on 18?
(In reply to Aaron Train [:aaronmt] from comment #6)
> > tracking-fennec: ? → +
> > Priority: -- → P2
> 
> We're not interested in fixing this regression from 17 on 18?

Mark it for re-triage if you disagree.

Updated

5 years ago
tracking-fennec: + → ?
Can we get a tighter range?
Keywords: regressionwindow-wanted
as tight a range as available without bi-secting. Can someone do that? http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-10-24&enddate=2012-10-25
tracking-fennec: ? → +
I confirmed this bug was fixed on latest nightly: http://hg.mozilla.org/mozilla-central/rev/20d1a5916ef6. But I cannot specify the commit which fixed this bug.
status-firefox20: affected → fixed

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: regressionwindow-wanted, reproducible, smoketest → verifyme
Resolution: --- → FIXED

Updated

5 years ago
Keywords: verifyme
(Reporter)

Updated

5 years ago
status-firefox18: affected → fixed
status-firefox19: affected → fixed

Comment 12

5 years ago
Firefox 20.0a1 (2013-01-07)
Firefox 19.0a2 (2013-01-07)
Firefox 18 RC 1 (2013-01-07)
Device: Galaxy Nexus / Galaxy Tab 
OS: Android 4.1.1 / 3.1

I am not able to reproduce this following the steps from description. I will set the bug to Verified Fixed.
Status: RESOLVED → VERIFIED
status-firefox18: fixed → verified
status-firefox19: fixed → verified
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.