Closed Bug 815808 Opened 8 years ago Closed 8 years ago

Firefox does not play direct-coded inline video from iPython Notebook.

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 799318

People

(Reporter: djvj, Unassigned)

Details

iPython notebook is an interactive online environment for exploratory programming.

To replicate the issue, a local iPython notebook server needs to be installed and the notebook at the following URL loaded with it:

https://github.com/ipython/ipython/blob/master/docs/examples/notebooks/00_notebook_tour.ipynb

In the "video" section, the second example does not work with Firefox, but does with Chrome.

  from IPython.display import HTML
  video = open("animation.m4v", "rb").read()
  video_encoded = video.encode("base64")
  video_tag = '<video controls alt="test" src="data:video/x-m4v;base64,{0}">'.format(video_encoded)
  HTML(data=video_tag)

Basically, the server serves up generated video as in-line content base64-encoded directly in the "src" attribute of the video tag, and Firefox does not know how to deal with it:

  <video controls alt="test" src="data:video/x-m4v;base64,BASE64_ENCODED_VIDEO_CONTENT_HERE">

Problem reproduces on release Firefox and later.
Firefox doesn't support mp4 video. You need to offer a webm or theora encoding as well if you want universal playback on html5 browsers.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799318
You need to log in before you can comment on or make changes to this bug.