Closed Bug 815961 Opened 7 years ago Closed 7 years ago

After dragging & dropping a tab the tabstrip scrolls to center the tab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 20
Tracking Status
firefox17 - wontfix
firefox18 + verified
firefox19 + fixed
firefox20 + verified
firefox-esr17 - ---

People

(Reporter: Felipe, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

When I do a tab drag&drop operation, after I drop the tab on its desired position, the tabstrip then scrolls and centers the tab. This makes it confusing because I instantly lose track of where the tab went, and is specially confusing now that we have direct tab manipulation.

I imagine this is a bug (and not the way it's intended to be). If so I can try to find a regression range; I'm pretty sure it's recent.
I can reproduce since the build which bug 783282 had landing.
http://hg.mozilla.org/mozilla-central/rev/257e181b2a96
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120827104458

Screen capture : http://youtu.be/Q8KaXut9g3o

Steps to reproduce:
1. Open enough number of tabs and overflow tabstrip
2. Drag a tab to this side of the scroll button
3. And then drop the tab

Actual results:
Unexpected  scrolling happens

Expected results:
After the drop of the tab, The tab should be located in the immediate neighbor of the scroll button.
Blocks: 783282
Assigning to Dao to look into the regression. We're too late for the 17.0.1 release so not tracking there, or in esr17 which wouldn't take a fix for something like this without significant user requests, but we'll hope for a fix on trunk & branches here to minimize the amount of exposure to this regression.
I just tested on my computer too and it does happen since the landing of 783282, I just had never noticed before. Thanks for the screen capture, Alice!
Attached patch patchSplinter Review
this was caused by moveTabTo being called before _finishAnimateTabMove
Attachment #688254 - Flags: review?(felipc)
Comment on attachment 688254 [details] [diff] [review]
patch

nice, fixes the problem for me! thanks
Attachment #688254 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/bfb0857b2751
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 688254 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 783282
User impact if declined: see comment 0
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #688254 - Flags: approval-mozilla-beta?
Attachment #688254 - Flags: approval-mozilla-aurora?
Comment on attachment 688254 [details] [diff] [review]
patch

Approving on branches as its a low risk fix for a regression in FF17.Will request QA to help with some manual testing around this bug alongside.
Attachment #688254 - Flags: approval-mozilla-beta?
Attachment #688254 - Flags: approval-mozilla-beta+
Attachment #688254 - Flags: approval-mozilla-aurora?
Attachment #688254 - Flags: approval-mozilla-aurora+
QA,can we please get some manual verification/testing around the reported issue. Thanks !
QA Contact: jbecerra
I wasn't able to reproduce the issue, using the STR from comment 1. No unexpected scrolling happens for me.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120827030549

Any suggestions would be appreciated.
I re-tested this on Ubuntu and managed to reproduce the issue.

This is now fixed on Firefox 18 beta 4, build ID: 20121212073002
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed in Firefox 20 beta 2 (buildID: 20130227063501) using Ubuntu 12.04LTS 32-bit and Windows 7 64-bit following STR from comment 1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.