Closed Bug 815974 Opened 8 years ago Closed 8 years ago

[System] Remember geolocation permission for an app is broken

Categories

(Firefox OS Graveyard :: General, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

VERIFIED FIXED
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: jsmith, Assigned: gwagner)

References

Details

Attachments

(1 file)

Build:

Device - Unagi

Hashes

  <project name="gaia" path="gaia" remote="b2g" revision="1087df834f985c4d01db455eb60163789499e086"/>
  <project name="releases/gecko" path="gecko" remote="mozillaorg" revision="04c2d4fc726f99facfabf85ebe6376996cac5dc8"/>

Steps

1. Install MozQA WebRT Tester - http://mozqa.com/data/webapps/mozqa.com/appinstall.html
2. Launch it and go to firefox --> geolocation --> position.html
3. When the prompt appears to access your geolocation, select remember my choice
4. Exit the app and kill the app process through task manager
5. Launch the app again and go to firefox --> geolocation --> position.html

Expected:

No prompt should appear. Permissions should be granted automatically and the user's geolocation should be shown.

Actual:

Prompt appears again asking for whether to share location or not. Looks like remember my choice isn't working with geolocation.
blocking-basecamp: --- → ?
Apparently can happen in app or browser as well. Looks like this is plainly generally busted.
Whiteboard: DUPEME
This does block, but I'm pretty sure this is a dupe of another bug.

Doug?
Whiteboard: DUPEME
Flags: needinfo?(doug.turner)
blocking-basecamp: ? → +
Whiteboard: DUPEME
this is what gregor is working on.
Assignee: nobody → anygregor
Flags: needinfo?(doug.turner)
(In reply to Doug Turner (:dougt) from comment #3)
> this is what gregor is working on.

So there's no known bug tracking the work here then?
Duplicate of this bug: 816824
Generalizing cause we know this issue applies generally.
Summary: Installing an app, accessing geolocation and selecting remember my choice, exit app, return to it and access geolocation again - choice wasn't remembered → [System] Remember my permission for an app is broken
Attached patch patchSplinter Review
This is a special case for prompting because we don't require the geolocation permission in the manifest. It should work with all other APIs that use prompting.
Attachment #686944 - Flags: review?(jonas)
Whiteboard: DUPEME
Summary: [System] Remember my permission for an app is broken → [System] Remember geolocation permission for an app is broken
moving to general after seeing that this patch is on the platform side
Component: Gaia::System → General
Setting priority based on triage discussions.  Feel free to decrease priority if you disagree.
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/5ae27ec3d9ec
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Blocked on bug 817758.
Depends on: 817758
Verified on 12/31/2012 build.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.