pressing numbers fast in form boxes moves cursor backwards

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: matfb, Assigned: jchen)

Tracking

18 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox18 affected, firefox19 unaffected, firefox20 unaffected)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Android; Tablet; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121121124203

Steps to reproduce:

Every time i type in numbers in any form fields if you type to quickly the cursor goes back a step and causes words, passwords to be typed incorrectly, this seems to only happen on numbers not letters.


Actual results:

The cursor goes back a space when entering numbers quickly, only way im able to stop this is by typing numbers slowly.


Expected results:

It should have not gone back a space the cursor that is. I am running FireFox Beta 18, Android JellyBean 4.2.1 on a Nexus 7 32GB (UK)  Wifi only version. Not and Never has been rooted etc incase that helps.
(Reporter)

Updated

6 years ago
Severity: normal → major
Thanks for the bug report. Can you check if you experience the same behaviour in Nightly (http://nightly.mozilla.org) or Aurora (http://aurora.mozilla.org) for Android?
Assignee: nobody → nchen
Severity: major → normal
status-firefox18: --- → affected
Component: General → Keyboards and IME
OS: Linux → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 2

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> Thanks for the bug report. Can you check if you experience the same
> behaviour in Nightly (http://nightly.mozilla.org) or Aurora
> (http://aurora.mozilla.org) for Android?

Hi,

I went into settings and allowed installation from unknown sources. When i tried to Install Auroa it said 'Cannot Install'. No other errors or anything.

I then downloaded Nightly and it installed fine, also i could not reproduce the problem in Nightly so seems to be bug in Firefox Beta v18

Thanks!

Updated

6 years ago
status-firefox20: --- → unaffected
(Reporter)

Comment 3

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> Thanks for the bug report. Can you check if you experience the same
> behaviour in Nightly (http://nightly.mozilla.org) or Aurora
> (http://aurora.mozilla.org) for Android?

Hi,

I tried installing Auora again and it worked this time, again can't produce error in both Auora and Nightly.

Thanks!
Jim says in channel this may have been resolved via 805162.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 805162
Resolution: --- → FIXED

Updated

6 years ago
status-firefox19: --- → unaffected
(Reporter)

Comment 5

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #4)
> Jim says in channel this may have been resolved via 805162.

Hi,

Sorry I'm new to this. How do i fix it in Firefox 18 Beta if it's resolved ?

Thanks!
(In reply to Mathew from comment #5)
> (In reply to Aaron Train [:aaronmt] from comment #4)
> > Jim says in channel this may have been resolved via 805162.
> 
> Hi,
> 
> Sorry I'm new to this. How do i fix it in Firefox 18 Beta if it's resolved ?
> 
> Thanks!

No problem. The bug I mentioned, bug 805162 has a fix which is currently targeting Firefox 19. There might be a discussion soon to determine if that fix is risk-free enough to graduate it to Firefox 18 currently on Beta, if not, it will be have to wait for the Firefox 19 release.

In the meantime, you can continue to use either Aurora (19), or Nightly (20) both of which currently contain the fix.
(Reporter)

Comment 7

6 years ago
Thank you for replying. i will use Auroa :-) thanks!
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.