Nordic character (ISO-8859-1) does not work on PPCLinux

VERIFIED DUPLICATE of bug 74088

Status

()

Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 74088
17 years ago
16 years ago

People

(Reporter: Mats Soderstrom, Assigned: nhottanscp)

Tracking

({intl})

Trunk
mozilla1.2alpha
PowerPC
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-0d ppc; en-US; rv:0.9+) Gecko/20010517
BuildID:    20010516

When typing Swedish characters like "aring" a questionmark is shown instaed.
This goes for forms, composer, editor. This occured after 20010509.

Reproducible: Always
Steps to Reproduce:
1. Set your keyboard to use Swedish layout.
2. Type in  any of the three last characters in Swedish alphabet.
3.

Actual Results:  Questionmarks are being typed

Expected Results:  Swedish characters "aring" etc
Just a clarification: The last three characters are å, ä and ö. If you try the
Swedish kb layout with a U.S. keyboard, those characters will be assigned to
keys labeled [, ', and ;. 
(Assignee)

Comment 2

17 years ago
Is this a problem on Linux? The platform field is set to "Macintosh" and OS
field is set to "Linux" which is correct?

Comment 3

17 years ago
I believe it is related to (but not identical with) bug 80274. The symptoms are
similar, the timeline identical (80274 was first seen on a 20010510 build).

The difference is the platform (80274 is Windows only, so far) and the fact that
80274 changes the user's keyboard mapping to the default for given country and
this seems just to ruin his national characters.

Reporter: Do you get the same result "?" for all three Swedish characters? What
do you get typing "-" (the key where US keybards have "/")?
(Assignee)

Comment 4

17 years ago
Reassign to ftang, please if this is related to the BIDI landing.
Assignee: nhotta → ftang
nhotta, the user-agent string says "Linux 2.4.3-0d ppc"

So the platform _is_ Macintosh and the OS _is_ Linux.
(Reporter)

Comment 6

17 years ago
This does only affect the last three "Swedish" characters and it started to
occur on build 20010509 or at least that is where I first notised it. My setup
is linuxppc on macintosh hardware and only mozilla is affected. The rest of the
keybord keys are normal.  I have nightly builds from 200104 on my site if you
want to confirm. ftp://v905-a84.hu.liu.se

Comment 7

17 years ago
I have no clue about Linux PPC. 
Leaf- do you know who port Linux PPC? Can you reassign this to him?
Assignee: ftang → leaf
Summary: Nordic character (ISO-8859-1) does not work → Nordic character (ISO-8859-1) does not work on PPCLinux

Comment 8

17 years ago
Mats, are you building mozilla yourself?
(Reporter)

Comment 9

17 years ago
Yes, I build rpm packages for linuxppc from the source rpm:s  made by Blizzard.
(Assignee)

Comment 10

17 years ago
Patch is posted for bug 80274, please apply that and see if that fix your problem.
(Reporter)

Comment 11

17 years ago
I applied the patch to 2001052022 but it did not make any difference the problem
is still the same typing "å, ä and ö" will give "?,  ? and ?". I can paste in
these characters (as I just did ) but only from within mozilla not type them in
another apps window and then paste them in only from text in the mozilla window.
And I can't type them.

Comment 12

17 years ago
This sounds like a buglet/incompatibility with the new input layer that exists
for ppc/linux. If he cannot produce these characters _at all_ in a terminal
window then it will certainly not work for mozilla. 

Is this mozilla specific or not?
(Reporter)

Comment 13

17 years ago
As I stated before this is *only* a mozilla problem. I can surely produce these
characters in any (besides mozilla) X-windows application or in the console.
(Reporter)

Comment 14

17 years ago
If I type in any of å, ä and ö (which result in ?, ? and ?) in composer and
press the "Send" button this pop-up message appears:

>The message you composed contains characters not found in the selected
>Character Coding, so your message may become unreadable after you send it. To
>send it anyway, click OK. To return to the Composer window where you can
>choose a different Character Coding, click Cancel.

This does not make sence since Western (ISO-8859-1) is already selected.

Comment 15

17 years ago
Confirming bug based on comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Keywords: intl

Comment 16

17 years ago
back to internationalization default owner as this isn't a build config issue.
Assignee: leaf → nhotta
Priority: -- → P3
Target Milestone: --- → mozilla1.2
(Assignee)

Comment 17

17 years ago
Reassign to yokoyama, any relation with the keyboard problem you're working on?
Assignee: nhotta → yokoyama

Comment 18

17 years ago
I recently fixed keyboard issue for Bidi.  However the fix is only
for Windows Platform.  Reassigning to nhotta.
Assignee: yokoyama → nhotta
(Assignee)

Comment 19

17 years ago
Katakai san, can this be a generic Linux problem?
IQA, can this be tested on RedHat Linux with Swedish keyboard?

Comment 20

17 years ago
I believe this is bug 74088 and Frank has checked in this week.

Can anyone try with the latest build?
(Reporter)

Comment 21

17 years ago
It is working again in build 2001052413 on linuxPPC. I can type åÅäÄöÖ.

Thanks!

Comment 22

17 years ago
great! thank you very much for veritication.

Hotta-san, can you mark this as dup of bug 74088?

Comment 23

17 years ago

*** This bug has been marked as a duplicate of 74088 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 24

17 years ago
Verified as duplicate.  Please reopen in case someone disagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.