Closed Bug 816728 Opened 7 years ago Closed 6 years ago

Don't reset mock if we're not changing which packages are installed

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 974082

People

(Reporter: catlee, Unassigned)

Details

(Whiteboard: [mock][buildfaster])

right now we reset our mock environment and usually re-install the same packages over and over for each build.

we should save the list of packages that have been installed into the mock environment somewhere, and if the build we're doing is using the same set we can skip resetting the environment. we should still run the install step, which will be a noop in most cases, but allows us to update packages in the yum repo without having to clobber the mock environment on all the slaves.
I took a quick stab at this and ran into problems with subsequent mock --copyin steps:

20:16:21     INFO -  INFO: copying /home/cltbld/.ssh to /builds/mock_mozilla/mozilla-centos6-i386/root/home/mock_mozilla/.ssh
20:16:21     INFO -  Traceback (most recent call last):
20:16:21     INFO -    File "/usr/sbin/mock_mozilla", line 862, in <module>
20:16:21     INFO -      main(retParams)
20:16:21     INFO -    File "/usr/sbin/mock_mozilla", line 821, in main
20:16:21     INFO -      shutil.copytree(src, dest)
20:16:21     INFO -    File "/usr/lib64/python2.6/shutil.py", line 142, in copytree
20:16:21     INFO -      os.makedirs(dst)
20:16:21     INFO -    File "/usr/lib64/python2.6/os.py", line 157, in makedirs
20:16:21     INFO -      mkdir(name, mode)
20:16:21     INFO -  OSError: [Errno 17] File exists: '/builds/mock_mozilla/mozilla-centos6-i386/root/home/mock_mozilla/.ssh'
20:16:21    ERROR - Return code: 1
20:16:21    FATAL - Halting on failure while running ['mock_mozilla', '-r', u'mozilla-centos6-i386', '--copyin', '--unpriv', u'/home/cltbld/.ssh', u'/home/mock_mozilla/.ssh']
20:16:21    FATAL - Exiting 1

Maybe we should be fixing mock to not error out in this case?
Priority: -- → P2
Whiteboard: [mock] → [mock][buildfaster]
Product: mozilla.org → Release Engineering
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974082
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.