Closed Bug 816733 Opened 7 years ago Closed 10 months ago

Unfocused windows show glass next to fogged glass in the window-controls area with Australis tabs

Categories

(Firefox :: Theme, defect)

All
Windows Vista
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jaws, Unassigned)

References

Details

(Whiteboard: [Australis:P5])

Attachments

(1 file)

STR:
Use a build with Australis tabs on Windows 7 with Aero glass
Restore the window and focus a different window
Notice that the fog on the aero glass for Australis hits non-fogged glass where the window controls are located.

A couple things we could do here to solve this, but I'm not sure which one is best. MattN said that we could reduce the fog in that corner of the window so it doesn't touch the window controls. Another idea would be to show fog on the unfocused window controls.
Taking so I know to work on this.
Assignee: nobody → shorlander
Keywords: uiwanted
This may need some widget tweaks since this is using -moz-appearance for that IIRC.
Whiteboard: [Australis:M7]
Stephen:

Did you mean to unassign yourself from this bug?  Let me know,

-Mike
Assignee: nobody → shorlander
Flags: needinfo?(shorlander)
Don't remember doing that :) However we did talk about the solution being to extend the fog behind the buttons instead of clipping it so I may have done it after that.
Flags: needinfo?(shorlander)
Removing the items from M7 that do not block us from landing on m-c.
Whiteboard: [Australis:M7] → [Australis:M?]
(P5, but I don't have a Windows/glass box handy to see if this is so horrible as to be P4/P3)
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P5]
Technically, we can't draw behind the controls. We could only draw custom controls, but that seems overkill and would have other downsides, like the glow on hover not extending above the outer window shadow. I'd rather reduce the fog to not touch the controls or just wontfix this bug since it doesn't look too bad (IMHO) and becomes irrelevant with newer Windows versions.
Whiteboard: [Australis:M?][Australis:P5] → [Australis:M?][Australis:P5] [defect] p=0
No longer blocks: fxdesktopbacklog
Whiteboard: [Australis:M?][Australis:P5] [defect] p=0 → [Australis:M?][Australis:P5]
Whiteboard: [Australis:M?][Australis:P5] → [Australis:P5]
Duplicate of this bug: 1004408
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.