Crash [@ AddPendingRecompile] or [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ]

RESOLVED DUPLICATE of bug 816368

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 816368
6 years ago
3 years ago

People

(Reporter: gkw, Unassigned)

Tracking

({crash, regression})

Trunk
All
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(firefox20 affected)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-0de38d24-e436-455f-bec9-417672121129 .
============================================================= 

I had 117 tabs open and was just surfing randomly in a tab when it crashed.
(Reporter)

Comment 1

6 years ago
I crashes again - bp-f4a4a8ef-fe3e-4636-8937-89d562121129 with similar steps. [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ]
Crash Signature: [@ AddPendingRecompile] → [@ AddPendingRecompile] [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ]
Summary: Crash [@ AddPendingRecompile] → Crash [@ AddPendingRecompile] or [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ]

Comment 2

6 years ago
I just updated to the latest nightly (hg.mozilla.org/mozilla-central/rev/58a4e9501f7e) and I crashed on this 7 times in a row, all within 30 seconds for startup.  From some initial experiments, it's triggered by having GMail open.
(Reporter)

Comment 3

6 years ago
I didn't think I crashed this hard on yesterday's / day before's nightly.
status-firefox20: --- → affected
tracking-firefox20: --- → ?
Keywords: regression, regressionwindow-wanted, testcase-wanted

Comment 5

6 years ago
Oops, I think I'm really seeing bug 816368 which isn't in my nightly yet.  No GMail for me for the next 24 hours :)

Comment 6

6 years ago
... and if I manually check for update I see a new Nightly that doesn't have the aforementioned GMail startup crash.

Comment 7

6 years ago
I'm hitting this crash (and also bp-31e8356e-5309-4776-af18-5b33b2121130) 100% reliably about 10 seconds after startup every single time using the latest Birch nightly.

Comment 8

6 years ago
(I could be seeing bug 816368 since I have a gmail apptab...

Comment 9

6 years ago
For the three crash signatures, there are no crashes in 20.0a1/20121129074803 that contains the fix of bug 816368
Status: NEW → RESOLVED
Crash Signature: [@ AddPendingRecompile] [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ] → [@ AddPendingRecompile] [@ js::analyze::ScriptAnalysis::analyzeBytecode(JSContext*) ] [@ JSScript::makeTypes(JSContext*)]
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816368
tracking-firefox20: ? → ---
Keywords: regressionwindow-wanted, testcase-wanted
You need to log in before you can comment on or make changes to this bug.