Closed Bug 816913 Opened 8 years ago Closed 8 years ago

B2G RIL: update phoneState when there's an incoming call

Categories

(Core :: DOM: Device Interfaces, defect, P4)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla20
blocking-basecamp -
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: hsinyi, Assigned: hsinyi)

Details

Attachments

(1 file, 2 obsolete files)

We doesn't change gAudioManager.phoneState to PHONE_STATE_RING_TONE correctly when there comes an incoming call. We should fix that.
Assignee: nobody → htsai
Comment on attachment 687017 [details] [diff] [review]
patch: update gAudioManager.phoneState as PHONE_STATE_RING_TONE

Should address comments per discussion.
Attachment #687017 - Flags: review?(allstars.chh)
Attached patch Patch v2 (obsolete) — Splinter Review
This patch gathered scatters of 'active call determination' in ril_worker and RadioInterfaceLayer. The determination was centralized in 'updateCallAudioState()'
Attachment #687017 - Attachment is obsolete: true
Attached patch Patch v2Splinter Review
This is the correct v2.
Attachment #687654 - Attachment is obsolete: true
Attachment #687656 - Flags: review?(allstars.chh)
Attachment #687656 - Flags: review?(allstars.chh) → review+
blocking-basecamp: --- → ?
This patch LGTM. AudioManager use MODE_RING to work-around the sound-leakage problem(for ex, answer MT call, the ringtone may delay several m-sec to stop).
(In reply to Randy Lin [:rlin] from comment #5)
> This patch LGTM. AudioManager use MODE_RING to work-around the sound-leakage
> problem(for ex, answer MT call, the ringtone may delay several m-sec to
> stop).

Randy, thanks for your feedback :)
bb? because we should fix the wrong phoneState.
Hsin-Yi, what will happen if we don't fix this?
Flags: needinfo?(htsai)
Hi Andrew,

If we don't fix this bug, there could be ringtone leakage problem. I.e. When you answer the incoming call by press the answer key, the ringetone would still play, and the remote party may hear that sound.
Details as Randy explained in comment 5. Thanks!
Flags: needinfo?(htsai)
Soft blocking.
blocking-basecamp: ? → -
Priority: -- → P4
https://hg.mozilla.org/mozilla-central/rev/2bf2896077db
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 687656 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: please see comment 9
Testing completed (on m-c, etc.): pushed to m-c already
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: no
Attachment #687656 - Flags: approval-mozilla-aurora?
Comment on attachment 687656 [details] [diff] [review]
Patch v2

no bb+ but also doesn't look to affect mainstream FF so approving for uplift.
Attachment #687656 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.