The default bug view has changed. See this FAQ.

B2G Cannot load extensions

RESOLVED FIXED in Firefox 19

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: benfrancis, Assigned: lightsofapollo)

Tracking

(Blocks: 1 bug)

unspecified
B2G C3 (12dec-1jan)
Dependency tree / graph

Firefox Tracking Flags

(firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

(Whiteboard: QARegressExclude)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
If you generate your Gaia profile with "DEBUG=1 make" it appears httpd.js doesn't run when you start B2G Desktop, B2G starts but just displays "Unable to connect", there's nothing running on port 8080.

This means Gaia developers must re-build Gaia as packaged apps for every small change they make.

httpd.js starts fine if you run Firefox with the same profile.

Tested with nightly (beta) build of B2G Desktop and the tip of Gaia.
(Reporter)

Updated

4 years ago
Blocks: 816961
FWIW, I have several nightly Aurora builds of B2G Desktop for OS X lying around, and httpd.js still works if I revert to an earlier version.

On this one from 2012-11-19, httpd still works:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2012-11-19-03-03-13-mozilla-aurora/b2g-18.0a2.en-US.mac64.dmg

But, when I update to this one on 2012-11-30, httpd stops working:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2012-11-30-03-03-33-mozilla-aurora/b2g-19.0a2.en-US.mac64.dmg

And, in -jsconsole, I see these errors:

http://dl.dropbox.com/u/2798055/Screenshots/w.png

Trying to copy & paste from jsconsole is crashing B2G Desktop for me right now, sorry for the image.

I'm a little in over my head trying to bisect this issue in b2g-desktop builds, but maybe someone can use the above info as a start.
FWIW, I managed to narrow the range of builds down to 2012-11-24 and 2012-11-28

httpd.js works:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2012-11-24-03-08-25-mozilla-aurora/b2g-19.0a2.en-US.mac64.dmg

httpd.js fails:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2012-11-28-03-07-55-mozilla-aurora/b2g-19.0a2.en-US.mac64.dmg
OK I am fairly sure 811784 breaks us here. The landing range is right and it seems to have causes similar problems in other areas.
(Assignee)

Updated

4 years ago
Summary: Gaia DEBUG builds not working under B2G Desktop → B2G Cannot load extensions
Created attachment 691019 [details] [diff] [review]
Resolves scoping issues
Attachment #691019 - Flags: review?(khuey)
Attachment #691019 - Attachment is patch: true
Attachment #691019 - Flags: review?(khuey) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/241296b53553
Assignee: nobody → jlal
OS: Linux → All
Hardware: x86_64 → All
I did rm -Rf profile && DEBUG=1 make && ~/path/to/b2g-desktop-objdir/dist/bin/b2g-bin -profile $PWD/profile and that also is working as described in bug 813230 comment 6. Great!
https://hg.mozilla.org/mozilla-central/rev/241296b53553
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 691019 [details] [diff] [review]
Resolves scoping issues

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Breaks b2g-desktop for gaia development
User impact if declined: Hinders gaia development 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Very minimal small syntax differences to achieve the same goal.
String or UUID changes made by this patch: 

--

Will greatly help gaia development we use extensions to load things like httpd.js. We have relied on that functionality for the better part of 5 months now.
Attachment #691019 - Flags: approval-mozilla-beta?
Attachment #691019 - Flags: approval-mozilla-aurora?
Comment on attachment 691019 [details] [diff] [review]
Resolves scoping issues

[Triage Comment]
Attachment #691019 - Flags: approval-mozilla-beta?
Attachment #691019 - Flags: approval-mozilla-b2g18+
Attachment #691019 - Flags: approval-mozilla-aurora?
Attachment #691019 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Blocks: 813230
https://hg.mozilla.org/releases/mozilla-aurora/rev/c0ed4a465b7a
https://hg.mozilla.org/releases/mozilla-b2g18/rev/dd792d11185c
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Keywords: checkin-needed
Whiteboard: blocking-development
Target Milestone: --- → B2G C3 (12dec-1jan)

Updated

4 years ago
Whiteboard: QARegressExclude
You need to log in before you can comment on or make changes to this bug.