Closed Bug 817327 Opened 7 years ago Closed 7 years ago

Import bookmarks is broken in SeaMonkey

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.14 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 801450

People

(Reporter: therealvitotuxedo, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14
Build ID: 20121118021015

Steps to reproduce:

Used the Bookmarks Manager's "Import HTML..." command under the Tools menu, checked the "Import Bookmarks from: File" radio button, clicked "Continue", and then used the file browser to select a Safari Bookmarks.html file. Clicked "Open". 


Actual results:

The Bookmarks Manager does nothing. There is no progress bar, or any other indication that it has imported the bookmarks file. The Safari bookmarks do not appear anywhere in the bookmarks directory. Quitting and relaunching SeaMonkey does not reveal the Safari bookmarks. Multiple attempts to perform the import gave the same result. The Safari Bookmarks.html file opens and displays the correct contents when opened directly in the SeaMonkey browser, but SeaMonkey will not import the bookmarks and list them in the bookmarks directory, or display them in the Bookmarks Manager.


Expected results:

The Safari bookmarks should have been added to the bookmarks directory, and they should be listed in the Bookmarks Manager.
Can you provide example of that Safari bookmark file?
Bookmarks HTML file exported from Safari attached to the bug on 2012, Dec. 02.
(This is from Aurora, so line number may not match on Release, but...)

> Error: this._curFrame is undefined
> Source File: resource://gre/modules/BookmarkHTMLUtils.jsm
> Line: 292

> Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: Component returned failure
> code: 0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)
> [nsINavBookmarksService.runInBatchMode]
> Source File: resource://gre/modules/BookmarkHTMLUtils.jsm
> Line: 733
http://support.mozilla.org/en-US/questions/938940#answer-373325

> You will have to remove all FOLDED attributes in the H3 tags with a plain text editor.
> Then importing should work.

> %s/<h3 folded="">//
 
 
Doing so, & it does.
Suppose this can be marked as DUP Bug 801450 - Can't import bookmarks from Safari-created HTML files
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801450
Yes, I agree that this bug appears to be a duplicate of Bug 801450. I searched Bugzilla for a similar bug before submitting this one, but the search didn't find Bug 801450.

Thanks for following up on this and resolving it to the duplicate status.
You need to log in before you can comment on or make changes to this bug.