Intermittent testBookmark | Tapping star button bookmarked page - got true, expected false

RESOLVED FIXED in Firefox 24

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: RyanVM, Assigned: gbrown)

Tracking

({intermittent-failure})

20 Branch
Firefox 25
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=17521603&tree=Mozilla-Inbound

Android no-ionmonkey Tegra 250 mozilla-inbound opt test robocop on 2012-12-01 08:52:02 PST for push 6477f8bf2be5
slave: tegra-262

0 INFO SimpleTest START
1 INFO TEST-START | testBookmark
2 INFO TEST-PASS | testBookmark | checking that bookmarks list exists - bookmarks list exists
3 INFO TEST-PASS | testBookmark | bookmarks list has 4 children (the default bookmarks) - 4 should equal 4
4 INFO TEST-PASS | testBookmark | Find default bookmark - Default bookmark for about:firefox found
5 INFO TEST-PASS | testBookmark | Find default bookmark - Default bookmark for about:home found
6 INFO TEST-PASS | testBookmark | Find default bookmark - Default bookmark for https://addons.mozilla.org/en-US/android/ found
7 INFO TEST-PASS | testBookmark | Find default bookmark - Default bookmark for http://support.mozilla.org/en-US/mobile found
8 INFO TEST-PASS | testBookmark | bookmarks list has 5 children (the default bookmarks and the new one) - 5 should equal 5
9 INFO TEST-PASS | testBookmark | Page is not bookmarked initially - false should equal false
10 INFO TEST-PASS | testBookmark | Awesomebar URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_01.html
11 INFO TEST-PASS | testBookmark | bookmark added successfully - true should equal true
12 INFO TEST-PASS | testBookmark | Awesomebar URL typed properly - about:firefox should equal about:firefox
13 INFO TEST-PASS | testBookmark | Tapping star button bookmarked page - true should equal true
14 INFO TEST-PASS | testBookmark | Awesomebar URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_01.html
15 INFO TEST-PASS | testBookmark | bookmark removed successfully - true should equal true
16 INFO TEST-UNEXPECTED-FAIL | testBookmark | Tapping star button bookmarked page - got true, expected false
Exception caught during test!
junit.framework.AssertionFailedError: 16 INFO TEST-UNEXPECTED-FAIL | testBookmark | Tapping star button bookmarked page - got true, expected false
	at junit.framework.Assert.fail(Assert.java:47)
	at org.mozilla.fennec.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:107)
	at org.mozilla.fennec.FennecMochitestAssert.ok(FennecMochitestAssert.java:136)
	at org.mozilla.fennec.FennecMochitestAssert.is(FennecMochitestAssert.java:142)
	at org.mozilla.fennec.tests.testBookmark.runMenuTest(testBookmark.java:67)
	at org.mozilla.fennec.tests.testBookmark.testBookmark(testBookmark.java:56)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:120)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
17 INFO TEST-UNEXPECTED-FAIL | testBookmark | Exception caught - junit.framework.AssertionFailedError: 16 INFO TEST-UNEXPECTED-FAIL | testBookmark | Tapping star button bookmarked page - got true, expected false
18 INFO TEST-END | testBookmark | finished in 85653ms
19 INFO TEST-START | Shutdown
20 INFO Passed: 14
21 INFO Failed: 2
22 INFO Todo: 0
23 INFO SimpleTest FINISHED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Wes, any ideas about this one? (It's regressed fairly recently)
Flags: needinfo?(wjohnston)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Blocks: 819414
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Top-orange; disabled for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e03c4bae1106
Whiteboard: [test disabled][leave open]
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 40

7 years ago
Test improved and enabled in bug 769919 with no sign of this failure.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: needinfo?(wjohnston)
Resolution: --- → DUPLICATE
Whiteboard: [test disabled][leave open]
Duplicate of bug: 769919
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 67

6 years ago
I see 2 cases in the failure logs here, both in runMenuTest:
1. verify url is not bookmarked
   loadAndPaint(url)
   select MENU > Bookmark
   verify "Bookmark added" is displayed
   loadAndPaint("about:home")
   verify url is bookmarked via BrowserDB.isBookmark >> intermittent FAIL
2. after (1)...
   loadAndPaint(url)
   select MENU > Bookmark
   verify "Bookmark removed" is displayed
   loadAndPaint("about:home")
   verify url is not bookmarked via BrowserDB.isBookmark >> intermittent FAIL

Note that in both cases, the test verified with UI feedback that a bookmark was added/removed...only to fail when re-verifying via BrowserDB.isBookmark.
Assignee: nobody → gbrown
Assignee

Comment 68

6 years ago
Speculative fix: We "only" wait for 3000 ms for the expected response from isBookmarked -- maybe that is sometimes not enough for the database to be updated, especially on an overworked, aging tegra. (I noticed a couple of typos too!)
Attachment #773732 - Flags: review?(wjohnston)
Attachment #773732 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/ddb4799e1e22
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.