no keyup event triggered on Alt key up after any other key up when pressed together

RESOLVED DUPLICATE of bug 347010

Status

()

RESOLVED DUPLICATE of bug 347010
6 years ago
6 years ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: S)

(Reporter)

Description

6 years ago
STR :

Apply the following script using scratchpad to any page

document.addEventListener("keydown", function(e) {console.log("down " + e.keyCode);}, true);
document.addEventListener("keypress", function(e) {console.log("press " + e.charCode);}, true);
document.addEventListener("keyup", function(e) {console.log("up " + e.keyCode);}, true);

then do the following key sequence

1. Alt down
2. R down
3. R up
4. Alt up

(any other key can be used in step 2 and 3)

the last Alt up does not trigger a keyup event and the console logs can be used to verify that
On Linux there is alt-up, but I don't see it on Windows.
(Reporter)

Updated

6 years ago
Summary: no keyup event after second key lifted → no keyup event triggered on Alt key up after any other key up when pressed together
Whiteboard: S
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347010
You need to log in before you can comment on or make changes to this bug.