Closed Bug 817476 Opened 8 years ago Closed 8 years ago

_Really_ convert Screen to WebIDL

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(1 file)

We sort of failed to SetIsDOMBinding(), so it's still getting XPConnect objects and all that.
Attachment #687640 - Flags: review?(Ms2ger)
Comment on attachment 687640 [details] [diff] [review]
Really do WebIDL bindings for Screen.

Review of attachment 687640 [details] [diff] [review]:
-----------------------------------------------------------------

Gah, I suck at this.
Attachment #687640 - Flags: review?(Ms2ger) → review+
Whiteboard: [need review]
Hey, I reviewed, so we can blame ourselves together.  ;)
Note, due to this bug this:

  document.writeln(Screen.prototype);
  document.writeln(screen.__proto__);
  document.writeln(screen.__proto__ == Screen.prototype);

writes out two different objects and then false.  If the order of the first two calls is reversed, you get the same object (the xpconnect proto) and then true.

So we probably want to take this on Aurora.
https://hg.mozilla.org/integration/mozilla-inbound/rev/f6e5cfa9dd01
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla20
Comment on attachment 687640 [details] [diff] [review]
Really do WebIDL bindings for Screen.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 793244 
User impact if declined: There can be weirdness where defining a function on
   window.Screen.prototype doesn't make it appear on window.screen.
Testing completed (on m-c, etc.): Passes attached test.
Risk to taking this patch (and alternatives if risky): Low risk, I believe.  The
   other option is to back out bug 793244 which might actually be more risky.
String or UUID changes made by this patch: None.
Attachment #687640 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f6e5cfa9dd01
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 687640 [details] [diff] [review]
Really do WebIDL bindings for Screen.

If a backout is riskier, then please go ahead with uplifting this to Aurora so we can get bake time there.
Attachment #687640 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.