Closed Bug 817519 Opened 8 years ago Closed 8 years ago

Firefox WebView

Categories

(Firefox for Android :: General, defect)

20 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 867517

People

(Reporter: steren.giannini, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11

Steps to reproduce:

Create an Android application containing a regular Android Webview.


Actual results:

This WebView does not support WebGL or other features supported by Firefox for Android.


Expected results:

It would be great if Mozilla created a FirefoxWebView, that has the same API than the regular Android Webview, but that would be using the engine of Firefox for Android.

This would allow me for example to build native apps containing a Webview displaying WebGL.
Brad/Mark, is this bug actionable or a dupe? If so, please new/resolve it.
OS: Mac OS X → Android
Hardware: x86 → ARM
Is there any plan for this? It would solve a few of our problems nicely. I'd be willing to contribute some development time towards it if this is anywhere on your roadmap.
No distinct plans now. It wouldn't be hard to repurpose Fennec to do this on its own (i.e. convert it to something that showed a single web page). Or as a more lightweight alternative, see our WebApps support, where we're exposing native api's to the web. We're also expanding so that apk's installed through the PlayStore (or other stores) could launch WebApps in Fennec.

We're also continually refactoring code to remove inter-dependencies, which isn't entirely orthogonal to the goal of implementing WebView interfaces. If there was a small subset you needed, filing individual bugs might be better than this. We have no plans to implement WebView interfaces just to implement them.
Dup of bug 867517 ?

/be
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to Brendan Eich [:brendan] from comment #4)
> Dup of bug 867517 ?
> 

Yep
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 867517
You need to log in before you can comment on or make changes to this bug.