Rotating device while in awesome screen might break toolbar layout

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: lucasr, Assigned: lucasr)

Tracking

unspecified
Firefox 20
All
Android
Points:
---

Firefox Tracking Flags

(fennec20+)

Details

Attachments

(3 attachments)

This is a small regression from bug 709433. We save the original margin used in the toolbar entry before animating. If the device is rotated while in awesome screen and then return to main browser UI, the animation to restore the toolbar size will use wrong margin (as the size of the toolbar in portrait and landscape are different).
tracking-fennec: --- → ?
I think this is what is causing this state where things are off for me (I did some rotation and playing around)
Duplicate of this bug: 818079
My original animation patch assumed the BrowserApp activity would stay alive while user is using the awesome screen which is an incorrect assumption. Also, on device rotation, we reinflate the toolbar layout causing the animation to start from an incorrect initial state to an invalid final state.

This patch ensures that the animation always starts from the correct state in all situations (when app is background killed, when "Don't keep activities" is on, when device rotates while in awesome screen, etc).
Attachment #689178 - Flags: review?(mark.finkle)
tracking-fennec: ? → 20+
Attachment #689178 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/03e4cc5b322d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Posted image Nightly 12/13
Firefox 20.0a1 (2012-12-13)
Device: Galaxy S2
OS: Android 4.0.3

This issue is reproducible on the latest Nightly. Is it related to this bug?
(In reply to Cristian Nicolae (:xti) from comment #6)
> Created attachment 691806 [details]
> Nightly 12/13
> 
> Firefox 20.0a1 (2012-12-13)
> Device: Galaxy S2
> OS: Android 4.0.3
> 
> This issue is reproducible on the latest Nightly. Is it related to this bug?

It's a different issue already being tracked in bug 817828.
Duplicate of this bug: 818874
I am not able to reproduce this on :
Firefox 20.0a1 (2012-12-18)
Device: Galaxy Nexus / Note 
OS: Android 4.1.1/ 4.0.4

Marking bug as VERIFIED FIXED..
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.